summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-09-17 10:17:50 +0200
committerMichał Górny <mgorny@gentoo.org>2020-09-17 10:34:20 +0200
commitda5ebb6aaf8d4cbd14d6cd84f0f8945de3d6bd36 (patch)
tree633d9a38199979d6057ea37070fc69546f679657 /dev-python/nbconvert
parentdev-python/cfn-python-lint: Bump to 0.36.0 (diff)
downloadgentoo-da5ebb6aaf8d4cbd14d6cd84f0f8945de3d6bd36.tar.gz
gentoo-da5ebb6aaf8d4cbd14d6cd84f0f8945de3d6bd36.tar.bz2
gentoo-da5ebb6aaf8d4cbd14d6cd84f0f8945de3d6bd36.zip
dev-python/nbconvert: Bump to 6.0.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/nbconvert')
-rw-r--r--dev-python/nbconvert/Manifest1
-rw-r--r--dev-python/nbconvert/nbconvert-6.0.3.ebuild72
2 files changed, 73 insertions, 0 deletions
diff --git a/dev-python/nbconvert/Manifest b/dev-python/nbconvert/Manifest
index b7cea49a902e..c4a474c1f66b 100644
--- a/dev-python/nbconvert/Manifest
+++ b/dev-python/nbconvert/Manifest
@@ -1,3 +1,4 @@
DIST nbconvert-5.6.1.tar.gz 703233 BLAKE2B e75d558aee6c66fe8e7455ecf22dbbcd2a0698380ffec80eff15aea6c70bc853daa9ab2fd1d114453bd5dfe7e75617afb9f5c1075704bfadbb59fef34bca88a9 SHA512 0c68adcb9f28ead9ec058fc2e02a9a1e6f65818709c99f7a006a59a7562b5f5ee74afe5287e41568c35542898dc1b43c4543d2386cc05a721b3f99d5cc789435
DIST nbconvert-6.0.1.tar.gz 838950 BLAKE2B 7ccb821bd7affab3faed0c1fb139b0641f295c71109c783e9ce40c5a4c15c2d87a327ce7c802ed3cfde2fcde4c360375dd751f9592eeda102d520aee4e94f2d5 SHA512 7c782a068fc004a42cbc2e09d8d4fbce5385a8f6fb8491fa39d14df123a00bf81e6e7f11885fe39300156ecf560b92f5631537a5956e5541ea3dcf9ec5f9f365
DIST nbconvert-6.0.2.tar.gz 847737 BLAKE2B c787840ec25661a1242bd1a4ef46ca0c022fd23385da5dc48ff8ec391ad440fc70ab841fdfd1fd0a98836a4a30592ed0f121ce94895f2a70c33899c11760e43b SHA512 faad2c4e697a0189e4b156e061f1d2a13676ef0dc7703993f0d445093d83a73618bc2529fceca094797415e7468e7f067d573556bfcf793a37956c082403d5fa
+DIST nbconvert-6.0.3.tar.gz 848214 BLAKE2B 4265486536cfe0cf220b8080374726cc68be4f15033c8248806579b1ea1f759caa667ae11738acce1ecc812c65b954be1c21db0abe69db7bfdf67533ea052c3c SHA512 55e6fc1f136f8bc3b4b662011172ac3f61354ee1afa6904b5df34a382ae96f46e13f097f6067ca5e42d3fd0049f81a8a27d7b7faf605fa948e22d6067bc971ef
diff --git a/dev-python/nbconvert/nbconvert-6.0.3.ebuild b/dev-python/nbconvert/nbconvert-6.0.3.ebuild
new file mode 100644
index 000000000000..bc104bb52acf
--- /dev/null
+++ b/dev-python/nbconvert/nbconvert-6.0.3.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Converting Jupyter Notebooks"
+HOMEPAGE="https://nbconvert.readthedocs.io/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/bleach[${PYTHON_USEDEP}]
+ dev-python/defusedxml[${PYTHON_USEDEP}]
+ >=dev-python/entrypoints-0.2.2[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/jupyter_core[${PYTHON_USEDEP}]
+ dev-python/jupyterlab_pygments[${PYTHON_USEDEP}]
+ >=dev-python/mistune-0.7.4[${PYTHON_USEDEP}]
+ dev-python/nbclient[${PYTHON_USEDEP}]
+ dev-python/nbformat[${PYTHON_USEDEP}]
+ >=dev-python/pandocfilters-1.4.1[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-4.2.1[${PYTHON_USEDEP}]
+ dev-python/testpath[${PYTHON_USEDEP}]
+ www-servers/tornado[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pebble[${PYTHON_USEDEP}]
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ dev-python/ipywidgets[${PYTHON_USEDEP}]
+ >=dev-python/jupyter_client-4.2[${PYTHON_USEDEP}]
+ media-gfx/inkscape
+ )
+"
+
+distutils_enable_tests pytest
+
+src_test() {
+ mkdir -p "${HOME}/.local" || die
+ cp -r share "${HOME}/.local/" || die
+ distutils-r1_src_test
+}
+
+python_test() {
+ local deselect=(
+ # Missing pyppeteer for now
+ # TODO: Doesn't skip?
+ --deselect exporters/tests/test_webpdf.py
+ # Needs pyppeteer too
+ --deselect 'tests/test_nbconvertapp.py::TestNbConvertApp::test_webpdf_with_chromium'
+ )
+
+ distutils_install_for_testing bdist_egg
+ cd "${TEST_DIR}"/lib || die
+ pytest -vv "${deselect[@]}" --pyargs nbconvert || die "Tests failed with ${EPYTHON}"
+}
+
+pkg_postinst() {
+ if ! has_version app-text/pandoc ; then
+ einfo "Pandoc is required for converting to formats other than Python,"
+ einfo "HTML, and Markdown. If you need this functionality, install"
+ einfo "app-text/pandoc."
+ fi
+}