summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Brehler <marbre@linux.sungazer.de>2016-12-16 10:38:02 +0100
committerDavid Seifert <soap@gentoo.org>2017-01-04 12:14:55 +0200
commitf424861f2d93801ee76ce895049a6770c2e8d0f6 (patch)
treec2ebd8249996312a1032d5086470e2ea80cc3737 /dev-python/nbformat/nbformat-4.2.0.ebuild
parentdev-python/notebook: Version bump to 4.3.0 (diff)
downloadgentoo-f424861f2d93801ee76ce895049a6770c2e8d0f6.tar.gz
gentoo-f424861f2d93801ee76ce895049a6770c2e8d0f6.tar.bz2
gentoo-f424861f2d93801ee76ce895049a6770c2e8d0f6.zip
dev-python/nbformat: Version bump to 4.2.0
Package-Manager: portage-2.3.0 Closes: https://github.com/gentoo/gentoo/pull/3129
Diffstat (limited to 'dev-python/nbformat/nbformat-4.2.0.ebuild')
-rw-r--r--dev-python/nbformat/nbformat-4.2.0.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/nbformat/nbformat-4.2.0.ebuild b/dev-python/nbformat/nbformat-4.2.0.ebuild
new file mode 100644
index 000000000000..76fc1ca89c17
--- /dev/null
+++ b/dev-python/nbformat/nbformat-4.2.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} )
+PYTHON_REQ_USE='sqlite'
+
+inherit distutils-r1
+
+DESCRIPTION="Reference implementation of the Jupyter Notebook format"
+HOMEPAGE="http://jupyter.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND="
+ >=dev-python/jsonschema-2.4.0[${PYTHON_USEDEP}]
+ dev-python/ipython_genutils[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-4.1[${PYTHON_USEDEP}]
+ dev-python/jupyter_core[${PYTHON_USEDEP}]
+ "
+DEPEND="${RDEPEND}
+ doc? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/numpydoc[${PYTHON_USEDEP}]
+ )
+ test? (
+ dev-python/testpath[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ )
+ "
+
+python_prepare_all() {
+ # Prevent un-needed download during build
+ if use doc; then
+ sed -e "/^ 'sphinx.ext.intersphinx',/d" -i docs/conf.py || die
+ fi
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ if use doc; then
+ emake -C docs html
+ HTML_DOCS=( docs/_build/html/. )
+ fi
+}
+
+python_test() {
+ distutils_install_for_testing
+ cd "${TEST_DIR}"/lib || die
+ py.test -v --cov nbformat nbformat || die
+}