summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Brehler <marbre@linux.sungazer.de>2017-11-10 10:43:29 +0100
committerDavid Seifert <soap@gentoo.org>2017-11-17 19:43:17 +0100
commit4f5f8f7d68042af567fb58dd32f27db03c3e5aa5 (patch)
tree3303730eee019c14664a19762f70e1e6128dcc23 /dev-python/nbformat
parentmedia-sound/calf add USE flag to enable experimental plugins (diff)
downloadgentoo-4f5f8f7d68042af567fb58dd32f27db03c3e5aa5.tar.gz
gentoo-4f5f8f7d68042af567fb58dd32f27db03c3e5aa5.tar.bz2
gentoo-4f5f8f7d68042af567fb58dd32f27db03c3e5aa5.zip
dev-python/nbformat: Version bump to 4.4.0
Package-Manager: Portage-2.3.8, Repoman-2.3.3 Closes: https://github.com/gentoo/gentoo/pull/6167
Diffstat (limited to 'dev-python/nbformat')
-rw-r--r--dev-python/nbformat/Manifest1
-rw-r--r--dev-python/nbformat/nbformat-4.4.0.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/nbformat/Manifest b/dev-python/nbformat/Manifest
index 6d0558d46d68..6797f12d39a6 100644
--- a/dev-python/nbformat/Manifest
+++ b/dev-python/nbformat/Manifest
@@ -2,3 +2,4 @@ DIST nbformat-4.0.1.tar.gz 105767 SHA256 5261c957589b9dfcd387c338d59375162ba9ca8
DIST nbformat-4.1.0.tar.gz 108264 SHA256 dbf6c0ed0cb7c5a7184536368f1dd1ada2d48fd6f016e0f9e9b69236e28c0857 SHA512 606d8aa786fdbe8fe6d12d9a13886a49043b096a86ad180556f65f226d5031c98f6c80b4319de09292f2f17ed9e3a5038828c94a7306ed2abd78976e30fc08d4 WHIRLPOOL f01d3431fb007b12bbd892181781d87a700c01a28f1bf5308f4ae0f5c5dd63c768e926964848a3a21b6bd34e8d6d2b6c3d962b4dee1f034a387e45d2c3741a2e
DIST nbformat-4.2.0.tar.gz 110309 SHA256 389a5b630a30539074f238a48fb9864592f63d611baccfa2ffaf14ffe239de06 SHA512 4b1b4ae59948306d750e0e44f5443980de64f7ae1e4afd57299114e952b9733268bd54900ea8598e4ba14754c622fb1fe7eb13a29716c91941d79ba75031f543 WHIRLPOOL 9e7ab6e385be29502cbe7a76aee57017e5956ee71d825902ffe25d6fb4b092eab17a649c04dbee953efdbc34c309dc79fe71d10fa96a7b888c3b46608765ed5b
DIST nbformat-4.3.0.tar.gz 578765 SHA256 5febcce872672f1c97569e89323992bdcb8573fdad703f835e6521253191478b SHA512 f4727466b96bb1e1524e9c496898bf0e868fd85b65e325a9741f0debc4f9fd908652b0eb4d0d20ed68332d7770c21dcb41b63ec76dc6a7d1b3267f03a7f96757 WHIRLPOOL e6b55758042127ab40d14268d45b33d7d32b2fab42a1aeaef106e9f6aad144f4228221074fd6cfc287fea2274167534c970546afc1d8216bc90f51e29318dfc2
+DIST nbformat-4.4.0.tar.gz 113683 SHA256 f7494ef0df60766b7cabe0a3651556345a963b74dbc16bc7c18479041170d402 SHA512 46cb78bca374ef49c4461f230cbb8eb4af611d7be395a448680964c759d47fa8558dd07de96c43921ca171c486707dc823e278b724d9dab51bd30c3dab47ff6e WHIRLPOOL 744eb36a89490a05a9fc954fe08d2a3fa062f21c99b4ed5680c0d18ff9ad1d8b8b24b2da5648c2102863956d9cefc7f5eea14ab6f9da239ed718e15be26cce0b
diff --git a/dev-python/nbformat/nbformat-4.4.0.ebuild b/dev-python/nbformat/nbformat-4.4.0.ebuild
new file mode 100644
index 000000000000..703139c395c9
--- /dev/null
+++ b/dev-python/nbformat/nbformat-4.4.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+PYTHON_REQ_USE='sqlite'
+
+inherit distutils-r1
+
+DESCRIPTION="Reference implementation of the Jupyter Notebook format"
+HOMEPAGE="http://jupyter.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="doc test"
+
+RDEPEND="
+ >=dev-python/jsonschema-2.4.0[${PYTHON_USEDEP}]
+ dev-python/ipython_genutils[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-4.1[${PYTHON_USEDEP}]
+ dev-python/jupyter_core[${PYTHON_USEDEP}]
+ "
+DEPEND="${RDEPEND}
+ doc? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/numpydoc[${PYTHON_USEDEP}]
+ )
+ test? (
+ dev-python/testpath[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ )
+ "
+
+python_prepare_all() {
+ # Prevent un-needed download during build
+ if use doc; then
+ sed -e "/^ 'sphinx.ext.intersphinx',/d" -i docs/conf.py || die
+ fi
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ if use doc; then
+ emake -C docs html
+ HTML_DOCS=( docs/_build/html/. )
+ fi
+}
+
+python_test() {
+ distutils_install_for_testing
+ cd "${TEST_DIR}"/lib || die
+ py.test -v --cov nbformat nbformat || die
+}