summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeffrey Lin <jeffrey@icurse.nl>2018-10-23 17:53:08 -0400
committerMichał Górny <mgorny@gentoo.org>2018-11-02 22:14:28 +0100
commita97d44c1e172e9eba95dbc9edb294e2087405b39 (patch)
treeccefb36c03f7ce0c5abf3c0bbb8c95aad0c73930 /dev-python/neovim-remote/neovim-remote-2.1.0.ebuild
parentdev-lang/go: remove 1.9 (diff)
downloadgentoo-a97d44c1e172e9eba95dbc9edb294e2087405b39.tar.gz
gentoo-a97d44c1e172e9eba95dbc9edb294e2087405b39.tar.bz2
gentoo-a97d44c1e172e9eba95dbc9edb294e2087405b39.zip
dev-python/neovim-remote: version bump to 2.1.0
Signed-off-by: Jeffrey Lin <jeffrey@icurse.nl> Package-Manager: Portage-2.3.51, Repoman-2.3.11 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/neovim-remote/neovim-remote-2.1.0.ebuild')
-rw-r--r--dev-python/neovim-remote/neovim-remote-2.1.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/neovim-remote/neovim-remote-2.1.0.ebuild b/dev-python/neovim-remote/neovim-remote-2.1.0.ebuild
new file mode 100644
index 000000000000..d77fc60b85e8
--- /dev/null
+++ b/dev-python/neovim-remote/neovim-remote-2.1.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+inherit distutils-r1
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/mhinz/${PN}.git"
+else
+ KEYWORDS="~amd64"
+ SRC_URI="https://github.com/mhinz/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+DESCRIPTION="A tool that helps control neovim processes"
+HOMEPAGE="https://github.com/mhinz/neovim-remote"
+LICENSE="MIT"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/neovim-python-client[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+DEPEND="${RDEPEND}
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+
+python_test() {
+ pytest -vv || die
+}