summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeffrey Lin <jeffrey@icurse.nl>2019-10-05 17:19:52 -0400
committerJoonas Niilola <juippis@gentoo.org>2019-10-09 08:21:26 +0300
commit14eb6706a5a099c77bbabd0814f3dd50f4970f0f (patch)
tree391c59265c175301b0aeb49b2fd4390527439757 /dev-python/neovim-remote/neovim-remote-2.2.1.ebuild
parentapp-crypt/acme-sh: update live ebuild (diff)
downloadgentoo-14eb6706a5a099c77bbabd0814f3dd50f4970f0f.tar.gz
gentoo-14eb6706a5a099c77bbabd0814f3dd50f4970f0f.tar.bz2
gentoo-14eb6706a5a099c77bbabd0814f3dd50f4970f0f.zip
dev-python/neovim-remote: version bump to 2.2.1
Closes: https://bugs.gentoo.org/696636 Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Jeffrey Lin <jeffrey@icurse.nl> Closes: https://github.com/gentoo/gentoo/pull/13177 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-python/neovim-remote/neovim-remote-2.2.1.ebuild')
-rw-r--r--dev-python/neovim-remote/neovim-remote-2.2.1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/neovim-remote/neovim-remote-2.2.1.ebuild b/dev-python/neovim-remote/neovim-remote-2.2.1.ebuild
new file mode 100644
index 000000000000..c07980e22fc2
--- /dev/null
+++ b/dev-python/neovim-remote/neovim-remote-2.2.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{5,6,7} )
+
+inherit distutils-r1
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/mhinz/${PN}.git"
+else
+ KEYWORDS="~amd64 ~arm"
+ SRC_URI="https://github.com/mhinz/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+DESCRIPTION="A tool that helps control neovim processes"
+HOMEPAGE="https://github.com/mhinz/neovim-remote"
+LICENSE="MIT"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/neovim-python-client[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+DEPEND="${RDEPEND}
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+
+python_test() {
+ pytest -vv || die
+}