summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-20 09:39:04 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-20 10:29:21 +0200
commitccbb2ea0e836a78977f7f2886054107c157935e5 (patch)
tree44591496ba103240c264713bc76167ca17edd7a9 /dev-python/neovim-remote
parentdev-python/cfn-lint: Bump to 0.60.1 (diff)
downloadgentoo-ccbb2ea0e836a78977f7f2886054107c157935e5.tar.gz
gentoo-ccbb2ea0e836a78977f7f2886054107c157935e5.tar.bz2
gentoo-ccbb2ea0e836a78977f7f2886054107c157935e5.zip
dev-python/neovim-remote: Bump to 2.5.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/neovim-remote')
-rw-r--r--dev-python/neovim-remote/Manifest1
-rw-r--r--dev-python/neovim-remote/neovim-remote-2.5.1.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/neovim-remote/Manifest b/dev-python/neovim-remote/Manifest
index 8f9a93992753..e7f711b97683 100644
--- a/dev-python/neovim-remote/Manifest
+++ b/dev-python/neovim-remote/Manifest
@@ -1 +1,2 @@
DIST neovim-remote-2.5.0.gh.tar.gz 439382 BLAKE2B b37317362b13dcb796d6a6ca0bd16b99b48154d9615af162d3da3898b080bbd87ae4624c37240498d73b92522a32a732cfc75ce8f69e172c97dd837b0965748e SHA512 872ad20f947a5ac99a1a91b925e1daa59e0c4ed6b7dbe9fede806dae2c3f1f5bc8bd660ba58513c41e402d39e2ad15d5f499d57e13782af7d10d8390a2737ea3
+DIST neovim-remote-2.5.1.gh.tar.gz 439548 BLAKE2B b57ddc0b8b432b65864bb560412684e6967db08ed09e1e7fe7294ba24d0d0aeb377f0f6fa38f4b0de44d5ea6bcc796ca2b8a491dda26eab870deab37f3608c59 SHA512 2d3c921485b18a9538f82b3a057834bdec5d8568a84528afaf52d73a69b60cf1eb6dee33f50a10d961fc0985c7a7d262a4edfc9f26f3ffd5d945472855fe3121
diff --git a/dev-python/neovim-remote/neovim-remote-2.5.1.ebuild b/dev-python/neovim-remote/neovim-remote-2.5.1.ebuild
new file mode 100644
index 000000000000..a7036334d63e
--- /dev/null
+++ b/dev-python/neovim-remote/neovim-remote-2.5.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/mhinz/${PN}.git"
+else
+ SRC_URI="
+ https://github.com/mhinz/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm"
+fi
+
+DESCRIPTION="A tool that helps control neovim processes"
+HOMEPAGE="
+ https://github.com/mhinz/neovim-remote/
+ https://pypi.org/project/neovim-remote/
+"
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="
+ dev-python/pynvim[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ app-editors/neovim
+ )
+"
+
+distutils_enable_tests pytest