summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-05 09:34:24 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-05 10:16:55 +0200
commitcd4105238604eb7c26de6de8479f4adcf023acd7 (patch)
tree4d847b963f9aa6f5db9dc4de8b9a3b04cd5dade9 /dev-python/neovim-remote
parentdev-util/stripe-mock: Bump to 0.125.0 (diff)
downloadgentoo-cd4105238604eb7c26de6de8479f4adcf023acd7.tar.gz
gentoo-cd4105238604eb7c26de6de8479f4adcf023acd7.tar.bz2
gentoo-cd4105238604eb7c26de6de8479f4adcf023acd7.zip
dev-python/neovim-remote: Bump to 2.4.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/neovim-remote')
-rw-r--r--dev-python/neovim-remote/Manifest1
-rw-r--r--dev-python/neovim-remote/neovim-remote-2.4.2.ebuild42
-rw-r--r--dev-python/neovim-remote/neovim-remote-9999.ebuild28
3 files changed, 62 insertions, 9 deletions
diff --git a/dev-python/neovim-remote/Manifest b/dev-python/neovim-remote/Manifest
index 2eab41f49497..de84c2754b82 100644
--- a/dev-python/neovim-remote/Manifest
+++ b/dev-python/neovim-remote/Manifest
@@ -1 +1,2 @@
DIST neovim-remote-2.4.0.tar.gz 438687 BLAKE2B 0dfbe3d660d9b2f6b7a4f1016d4d230d63612306ea99079364ed5c6dbae51df7a19c4d1bca51a7bfad142ffe5811e286b843edf6b0715c7aac921c584701030e SHA512 073bf95a0238c76c19258d886fe71e23ec85f9cba200b8a490014a2842d1a84b3c95092afcfdcc8ca80122639b9e07652594faa24ed6a6aff537192ec3a3d14c
+DIST neovim-remote-2.4.2.gh.tar.gz 438766 BLAKE2B e4ff3218e405da24f5146e38fec94d61953e2b89ef1bdae49a2ec925c3c1f953187fec51e9ea9a71c9265959212221fd73d59582a8f91fd4c03c734ad04e219f SHA512 4c39a28781d33bd179492816b2723dba4ef8e535813a25373c94852125b2b743732e98875c89111dce4a6329338c7d69837fed0dd9072740b1bf2b0f192855ab
diff --git a/dev-python/neovim-remote/neovim-remote-2.4.2.ebuild b/dev-python/neovim-remote/neovim-remote-2.4.2.ebuild
new file mode 100644
index 000000000000..a7036334d63e
--- /dev/null
+++ b/dev-python/neovim-remote/neovim-remote-2.4.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/mhinz/${PN}.git"
+else
+ SRC_URI="
+ https://github.com/mhinz/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm"
+fi
+
+DESCRIPTION="A tool that helps control neovim processes"
+HOMEPAGE="
+ https://github.com/mhinz/neovim-remote/
+ https://pypi.org/project/neovim-remote/
+"
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="
+ dev-python/pynvim[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ app-editors/neovim
+ )
+"
+
+distutils_enable_tests pytest
diff --git a/dev-python/neovim-remote/neovim-remote-9999.ebuild b/dev-python/neovim-remote/neovim-remote-9999.ebuild
index 15b4a3d9ac79..a7036334d63e 100644
--- a/dev-python/neovim-remote/neovim-remote-9999.ebuild
+++ b/dev-python/neovim-remote/neovim-remote-9999.ebuild
@@ -1,21 +1,29 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
-PYTHON_COMPAT=( python3_{7..10} )
inherit distutils-r1
if [[ ${PV} == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/mhinz/${PN}.git"
else
- SRC_URI="https://github.com/mhinz/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ SRC_URI="
+ https://github.com/mhinz/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
KEYWORDS="~amd64 ~arm"
fi
DESCRIPTION="A tool that helps control neovim processes"
-HOMEPAGE="https://github.com/mhinz/neovim-remote"
+HOMEPAGE="
+ https://github.com/mhinz/neovim-remote/
+ https://pypi.org/project/neovim-remote/
+"
LICENSE="MIT"
SLOT="0"
@@ -25,8 +33,10 @@ RDEPEND="
dev-python/psutil[${PYTHON_USEDEP}]
"
-distutils_enable_tests pytest
-
-BDEPEND+="
- test? ( app-editors/neovim )
+BDEPEND="
+ test? (
+ app-editors/neovim
+ )
"
+
+distutils_enable_tests pytest