summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-10-25 21:34:48 +0100
committerMichał Górny <mgorny@gentoo.org>2020-10-25 21:40:18 +0100
commit2b850c4269f0e34b7965e0276c0a80061607dd43 (patch)
tree61c2005ef879d0289c135c4d2a6540f1e9748772 /dev-python/nest_asyncio/nest_asyncio-1.4.2.ebuild
parentdev-python/virtualenv: Bump to 20.1.0 (diff)
downloadgentoo-2b850c4269f0e34b7965e0276c0a80061607dd43.tar.gz
gentoo-2b850c4269f0e34b7965e0276c0a80061607dd43.tar.bz2
gentoo-2b850c4269f0e34b7965e0276c0a80061607dd43.zip
dev-python/nest_asyncio: Bump to 1.4.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/nest_asyncio/nest_asyncio-1.4.2.ebuild')
-rw-r--r--dev-python/nest_asyncio/nest_asyncio-1.4.2.ebuild18
1 files changed, 18 insertions, 0 deletions
diff --git a/dev-python/nest_asyncio/nest_asyncio-1.4.2.ebuild b/dev-python/nest_asyncio/nest_asyncio-1.4.2.ebuild
new file mode 100644
index 000000000000..59e0ec644321
--- /dev/null
+++ b/dev-python/nest_asyncio/nest_asyncio-1.4.2.ebuild
@@ -0,0 +1,18 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Patch asyncio to allow nested event loops"
+HOMEPAGE="https://github.com/erdewit/nest_asyncio"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+distutils_enable_tests setup.py