summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2019-11-17 16:03:33 +0300
committerAlexey Shvetsov <alexxy@gentoo.org>2019-11-17 18:11:51 +0300
commit6eef4b9abf6c40d524b44d604ca6ecaa9feb715f (patch)
tree6a39b1ba3af63f1fe3a40c8e13835ea7854b9381 /dev-python/netcdf4-python/netcdf4-python-1.2.2-r1.ebuild
parentdev-python/GridDataFormats: Add py3.7 (diff)
downloadgentoo-6eef4b9abf6c40d524b44d604ca6ecaa9feb715f.tar.gz
gentoo-6eef4b9abf6c40d524b44d604ca6ecaa9feb715f.tar.bz2
gentoo-6eef4b9abf6c40d524b44d604ca6ecaa9feb715f.zip
dev-python/netcdf4-python: Add py3.7 and move to eapi7
Package-Manager: Portage-2.3.79, Repoman-2.3.18 Signed-off-by: Alexey Shvetsov <alexxy@gentoo.org>
Diffstat (limited to 'dev-python/netcdf4-python/netcdf4-python-1.2.2-r1.ebuild')
-rw-r--r--dev-python/netcdf4-python/netcdf4-python-1.2.2-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/netcdf4-python/netcdf4-python-1.2.2-r1.ebuild b/dev-python/netcdf4-python/netcdf4-python-1.2.2-r1.ebuild
new file mode 100644
index 000000000000..4494e2f43bc5
--- /dev/null
+++ b/dev-python/netcdf4-python/netcdf4-python-1.2.2-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+
+inherit distutils-r1
+
+MY_PN="netCDF4"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Python/numpy interface to the netCDF C library"
+HOMEPAGE="https://unidata.github.io/netcdf4-python/"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ dev-python/numpy
+ sci-libs/hdf5
+ sci-libs/netcdf:=[hdf,hdf5]"
+BDEPEND="${RDEPEND}"
+
+RESTRICT="!test? ( test )"
+
+S="${WORKDIR}"/${MY_P}
+
+python_test() {
+ cd test || die
+ ${PYTHON} run_all.py || die
+}