summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2017-08-25 15:27:36 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2017-08-25 15:27:36 -0500
commit2512ebb0ec311dfa6ff9442a26e6c1471e389152 (patch)
treee6f5addaced5bfb909922e3e27440b7d5966feac /dev-python/netifaces/netifaces-0.10.6.ebuild
parentdev-python/PyECLib: 1.5.0 bup (diff)
downloadgentoo-2512ebb0ec311dfa6ff9442a26e6c1471e389152.tar.gz
gentoo-2512ebb0ec311dfa6ff9442a26e6c1471e389152.tar.bz2
gentoo-2512ebb0ec311dfa6ff9442a26e6c1471e389152.zip
dev-python/netifaces: 0.10.6 bup
Package-Manager: Portage-2.3.6, Repoman-2.3.3
Diffstat (limited to 'dev-python/netifaces/netifaces-0.10.6.ebuild')
-rw-r--r--dev-python/netifaces/netifaces-0.10.6.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/netifaces/netifaces-0.10.6.ebuild b/dev-python/netifaces/netifaces-0.10.6.ebuild
new file mode 100644
index 000000000000..1062081a3ac6
--- /dev/null
+++ b/dev-python/netifaces/netifaces-0.10.6.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="Portable network interface information"
+HOMEPAGE="
+ https://pypi.python.org/pypi/netifaces/
+ http://alastairs-place.net/netifaces/
+ https://bitbucket.org/al45tair/netifaces"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""
+
+PATCHES=( "${FILESDIR}"/${PN}-0.10.4-remove-osx-fix.patch )