summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-06-15 09:17:44 +0200
committerMichał Górny <mgorny@gentoo.org>2022-06-15 13:32:42 +0200
commit0c0f2c6729d4b6c17e0f7c8dc713d4fc1ed63fcf (patch)
treec039e0c93c51394b3514aa89c36c62b873989dc4 /dev-python/networkx
parentdev-python/Babel: Bump to 2.10.2 (diff)
downloadgentoo-0c0f2c6729d4b6c17e0f7c8dc713d4fc1ed63fcf.tar.gz
gentoo-0c0f2c6729d4b6c17e0f7c8dc713d4fc1ed63fcf.tar.bz2
gentoo-0c0f2c6729d4b6c17e0f7c8dc713d4fc1ed63fcf.zip
dev-python/networkx: Bump to 2.8.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/networkx')
-rw-r--r--dev-python/networkx/Manifest1
-rw-r--r--dev-python/networkx/networkx-2.8.4.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/networkx/Manifest b/dev-python/networkx/Manifest
index d8b40488e4b2..ab109773eba2 100644
--- a/dev-python/networkx/Manifest
+++ b/dev-python/networkx/Manifest
@@ -1,4 +1,5 @@
DIST networkx-2.8.1.tar.gz 1945388 BLAKE2B 5c7ee6826f952d6f834d88ab0ba82d11d8a171611f43750d8d64ca6adf428fb64e8c37ca9c03654941c6d67eb8b68710e4e923f008c99d724ad47d42c31dc75d SHA512 a85b6be14aabb4f4d5317f65fca1d681d93bb6defdb81c4fe59b06e9632816adaa322ae7e8f2277a78290f0ac6260438b503c79d4cbb39fcd37562e8325d89d3
DIST networkx-2.8.2.tar.gz 1945873 BLAKE2B 212f42d8da35bb7c29b6feae626bb21036807e26996ff663dbb22b54908448715cbf6509553e2379a208b4537f03c92a3183a74a8074f4d2edae9b97084e5a8b SHA512 5b1ca05a009f78d693f8dfedaa51650d7834e4870d1a08fd8ea27f1293cbaccd9b4a2fb5d146df491e8dfcda1ca538786b257fb9b1250a383c59ea2b54188f55
DIST networkx-2.8.3.tar.gz 1947042 BLAKE2B a9d098023df1db6c94d531eba8797348d81b7cd52e22bbd421109be2e604b599de3a9a30c847682b53ce395ecc0522351db5f2f21b194be5ebd05c42d751a43c SHA512 1bcf606868f7041c1f412c0d853779c99f74be675b11b32727d502b78f8a672872291addfc7c8cba6bc7f464c2306a412862063e141853ab91999d2c54315214
+DIST networkx-2.8.4.tar.gz 1951336 BLAKE2B f45708eb8a642ee2561caf6b82b8947cc0ed8a90e22ff3424c54db728f6ab91bbaf78c62da113d02325c8f56418690386143c74f2098c670fe102c4e5ec78b9d SHA512 3f874e08a55d924905506fabdba1540745f7a1a99745531b49442206b6cac9b911674441d2241bc2c3e8c173635d53f2e5677fe76936630236ffb3fa021b2f9a
DIST networkx-2.8.tar.gz 1937426 BLAKE2B 5a094177ed480c6f7cbdacb6795fc4f2e0aec53ed89a33e19d78f47830d46238f35b7cd76098f6e00397f7cbdf305256910b7930cbb2c775ed4c2b18d9bd596f SHA512 72cd6637faa4228f6c802cf36935b5460fdf9b6cf191c3b375810bfc3732823e3286bdc1e6cbf7e6a7ffde83d0cf3bca157ae27ff98c537d43fdb4b8ef45ef4b
diff --git a/dev-python/networkx/networkx-2.8.4.ebuild b/dev-python/networkx/networkx-2.8.4.ebuild
new file mode 100644
index 000000000000..504ab461ddb9
--- /dev/null
+++ b/dev-python/networkx/networkx-2.8.4.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_FULLY_TESTED=( python3_{8..10} )
+# networkx skips tests w/ missing deps and the available ones all pass w/ py3.11
+PYTHON_COMPAT=( "${PYTHON_FULLY_TESTED[@]}" python3_11 )
+inherit distutils-r1 optfeature virtualx
+
+DESCRIPTION="Python tools to manipulate graphs and complex networks"
+HOMEPAGE="
+ https://networkx.org/
+ https://github.com/networkx/networkx/
+ https://pypi.org/project/networkx/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+
+BDEPEND="
+ test? (
+ >=dev-python/lxml-4.5[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.13[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/numpy-1.19[${PYTHON_USEDEP}]
+ >=dev-python/scipy-1.6.2[${PYTHON_USEDEP}]
+ ' "${PYTHON_FULLY_TESTED[@]}")
+ )
+"
+
+distutils_enable_tests pytest
+
+src_test() {
+ virtx distutils-r1_src_test
+}
+
+python_test() {
+ # virtx implies nonfatal
+ nonfatal epytest -p no:django || die
+}
+
+src_install() {
+ distutils-r1_src_install
+ # those examples use various assets and pre-compressed files
+ docompress -x /usr/share/doc/${PF}/examples
+}
+
+pkg_postinst() {
+ optfeature "recommended dependencies" "dev-python/matplotlib dev-python/numpy dev-python/pandas dev-python/scipy"
+ optfeature "graph drawing and graph layout algorithms" "dev-python/pygraphviz dev-python/pydot"
+ optfeature "YAML format reading and writing" "dev-python/pyyaml"
+ optfeature "shapefile format reading and writing" "dev-python/gdal"
+ optfeature "GraphML XML format" "dev-python/lxml"
+}