summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-07-10 21:14:51 +0200
committerMichał Górny <mgorny@gentoo.org>2022-07-10 21:16:24 +0200
commitce9430e3264366271a69a7adb843fe80fd252041 (patch)
treed0eae097a24a4abff763b199f0e1819f3859af3d /dev-python/networkx
parentdev-python/pymdown-extensions: Remove old (diff)
downloadgentoo-ce9430e3264366271a69a7adb843fe80fd252041.tar.gz
gentoo-ce9430e3264366271a69a7adb843fe80fd252041.tar.bz2
gentoo-ce9430e3264366271a69a7adb843fe80fd252041.zip
dev-python/networkx: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/networkx')
-rw-r--r--dev-python/networkx/Manifest2
-rw-r--r--dev-python/networkx/networkx-2.8.2.ebuild58
-rw-r--r--dev-python/networkx/networkx-2.8.3.ebuild66
3 files changed, 0 insertions, 126 deletions
diff --git a/dev-python/networkx/Manifest b/dev-python/networkx/Manifest
index 4654aefa8160..f93a50fafee3 100644
--- a/dev-python/networkx/Manifest
+++ b/dev-python/networkx/Manifest
@@ -1,3 +1 @@
-DIST networkx-2.8.2.tar.gz 1945873 BLAKE2B 212f42d8da35bb7c29b6feae626bb21036807e26996ff663dbb22b54908448715cbf6509553e2379a208b4537f03c92a3183a74a8074f4d2edae9b97084e5a8b SHA512 5b1ca05a009f78d693f8dfedaa51650d7834e4870d1a08fd8ea27f1293cbaccd9b4a2fb5d146df491e8dfcda1ca538786b257fb9b1250a383c59ea2b54188f55
-DIST networkx-2.8.3.tar.gz 1947042 BLAKE2B a9d098023df1db6c94d531eba8797348d81b7cd52e22bbd421109be2e604b599de3a9a30c847682b53ce395ecc0522351db5f2f21b194be5ebd05c42d751a43c SHA512 1bcf606868f7041c1f412c0d853779c99f74be675b11b32727d502b78f8a672872291addfc7c8cba6bc7f464c2306a412862063e141853ab91999d2c54315214
DIST networkx-2.8.4.tar.gz 1951336 BLAKE2B f45708eb8a642ee2561caf6b82b8947cc0ed8a90e22ff3424c54db728f6ab91bbaf78c62da113d02325c8f56418690386143c74f2098c670fe102c4e5ec78b9d SHA512 3f874e08a55d924905506fabdba1540745f7a1a99745531b49442206b6cac9b911674441d2241bc2c3e8c173635d53f2e5677fe76936630236ffb3fa021b2f9a
diff --git a/dev-python/networkx/networkx-2.8.2.ebuild b/dev-python/networkx/networkx-2.8.2.ebuild
deleted file mode 100644
index d33023f9d699..000000000000
--- a/dev-python/networkx/networkx-2.8.2.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_TESTED=( python3_{8..10} )
-# networkx skips tests w/ missing deps and the available ones all pass w/ py3.11
-PYTHON_COMPAT=( "${PYTHON_TESTED[@]}" python3_11 )
-inherit distutils-r1 optfeature virtualx
-
-DESCRIPTION="Python tools to manipulate graphs and complex networks"
-HOMEPAGE="
- https://networkx.org/
- https://github.com/networkx/networkx/
- https://pypi.org/project/networkx/
-"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~ppc64 ~riscv x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
-
-BDEPEND="
- test? (
- >=dev-python/lxml-4.5[${PYTHON_USEDEP}]
- >=dev-python/pyyaml-3.13[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- >=dev-python/numpy-1.19[${PYTHON_USEDEP}]
- >=dev-python/scipy-1.6.2[${PYTHON_USEDEP}]
- ' "${PYTHON_TESTED[@]}")
- )
-"
-
-distutils_enable_tests pytest
-
-src_test() {
- virtx distutils-r1_src_test
-}
-
-python_test() {
- # virtx implies nonfatal
- nonfatal epytest -p no:django || die
-}
-
-src_install() {
- distutils-r1_src_install
- # those examples use various assets and pre-compressed files
- docompress -x /usr/share/doc/${PF}/examples
-}
-
-pkg_postinst() {
- optfeature "recommended dependencies" "dev-python/matplotlib dev-python/numpy dev-python/pandas dev-python/scipy"
- optfeature "graph drawing and graph layout algorithms" "dev-python/pygraphviz dev-python/pydot"
- optfeature "YAML format reading and writing" "dev-python/pyyaml"
- optfeature "shapefile format reading and writing" "dev-python/gdal"
- optfeature "GraphML XML format" "dev-python/lxml"
-}
diff --git a/dev-python/networkx/networkx-2.8.3.ebuild b/dev-python/networkx/networkx-2.8.3.ebuild
deleted file mode 100644
index d35715a5eaa1..000000000000
--- a/dev-python/networkx/networkx-2.8.3.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_FULLY_TESTED=( python3_{8..10} )
-# networkx skips tests w/ missing deps and the available ones all pass w/ py3.11
-PYTHON_COMPAT=( "${PYTHON_FULLY_TESTED[@]}" python3_11 )
-inherit distutils-r1 optfeature virtualx
-
-DESCRIPTION="Python tools to manipulate graphs and complex networks"
-HOMEPAGE="
- https://networkx.org/
- https://github.com/networkx/networkx/
- https://pypi.org/project/networkx/
-"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
-
-BDEPEND="
- test? (
- >=dev-python/lxml-4.5[${PYTHON_USEDEP}]
- >=dev-python/pyyaml-3.13[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- >=dev-python/numpy-1.19[${PYTHON_USEDEP}]
- >=dev-python/scipy-1.6.2[${PYTHON_USEDEP}]
- ' "${PYTHON_FULLY_TESTED[@]}")
- )
-"
-
-distutils_enable_tests pytest
-
-src_test() {
- virtx distutils-r1_src_test
-}
-
-python_test() {
- local EPYTEST_DESELECT=()
- if ! has_version "dev-python/scipy[${PYTHON_USEDEP}]"; then
- EPYTEST_DESELECT+=(
- networkx/algorithms/tree/tests/test_mst.py::test_random_spanning_tree_additive_small
- networkx/algorithms/tree/tests/test_mst.py::test_random_spanning_tree_multiplicative_small
- )
- fi
-
- # virtx implies nonfatal
- nonfatal epytest -p no:django || die
-}
-
-src_install() {
- distutils-r1_src_install
- # those examples use various assets and pre-compressed files
- docompress -x /usr/share/doc/${PF}/examples
-}
-
-pkg_postinst() {
- optfeature "recommended dependencies" "dev-python/matplotlib dev-python/numpy dev-python/pandas dev-python/scipy"
- optfeature "graph drawing and graph layout algorithms" "dev-python/pygraphviz dev-python/pydot"
- optfeature "YAML format reading and writing" "dev-python/pyyaml"
- optfeature "shapefile format reading and writing" "dev-python/gdal"
- optfeature "GraphML XML format" "dev-python/lxml"
-}