summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-07-31 07:33:01 +0200
committerMichał Górny <mgorny@gentoo.org>2020-07-31 08:20:55 +0200
commitd3c3e033be875073d586b408f0b7cea25529e388 (patch)
treee9fd210289a2e46cf3f34450ddfa0770cbdbfd47 /dev-python/networkx
parentdev-python/requests: Remove old (diff)
downloadgentoo-d3c3e033be875073d586b408f0b7cea25529e388.tar.gz
gentoo-d3c3e033be875073d586b408f0b7cea25529e388.tar.bz2
gentoo-d3c3e033be875073d586b408f0b7cea25529e388.zip
dev-python/networkx: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/networkx')
-rw-r--r--dev-python/networkx/networkx-2.4.ebuild59
1 files changed, 0 insertions, 59 deletions
diff --git a/dev-python/networkx/networkx-2.4.ebuild b/dev-python/networkx/networkx-2.4.ebuild
deleted file mode 100644
index 07a98d729cc8..000000000000
--- a/dev-python/networkx/networkx-2.4.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-# networkx-2.4 supports up to python3_8
-PYTHON_COMPAT=( python3_{6,7} )
-inherit distutils-r1 virtualx
-
-DESCRIPTION="Python tools to manipulate graphs and complex networks"
-HOMEPAGE="http://networkx.github.io/ https://github.com/networkx/networkx"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="examples extras pandas scipy test xml yaml"
-RESTRICT="!test? ( test )"
-
-REQUIRED_USE="
- test? ( extras pandas scipy xml yaml )"
-
-COMMON_DEPEND="
- >=dev-python/matplotlib-2.2.2[${PYTHON_USEDEP}]
- extras? (
- >=dev-python/pydot-1.2.4[${PYTHON_USEDEP}]
- >=dev-python/pygraphviz-1.5[${PYTHON_USEDEP}]
- >=sci-libs/gdal-1.10.0[python,${PYTHON_USEDEP}]
- )
- pandas? ( >=dev-python/pandas-0.23.3[${PYTHON_USEDEP}] )
- scipy? ( >=sci-libs/scipy-1.1.0[${PYTHON_USEDEP}] )
- xml? ( >=dev-python/lxml-4.2.3[${PYTHON_USEDEP}] )
- yaml? ( >=dev-python/pyyaml-3.13[${PYTHON_USEDEP}] )"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- >=dev-python/decorator-4.3.0[${PYTHON_USEDEP}]
- ${COMMON_DEPEND}
- test? (
- dev-python/nose[${PYTHON_USEDEP}]
- )"
-RDEPEND="
- >=dev-python/decorator-4.3.0[${PYTHON_USEDEP}]
- ${COMMON_DEPEND}
- examples? (
- dev-python/pyparsing[${PYTHON_USEDEP}]
- )"
-
-PATCHES=(
-)
-
-python_test() {
- virtx nosetests -vv
-}
-
-python_install_all() {
- use examples && dodoc -r examples
-
- distutils-r1_python_install_all
-}