summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-04-12 13:12:01 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2019-04-12 14:43:40 -0500
commit1827193fd9cfc6edb28e11981d4812dcf0fed59e (patch)
tree6fbea92dfb71f44a47df7a708c21deedf844e86a /dev-python/neutron-lib/neutron-lib-1.25.0.ebuild
parentdev-python/os-traits: 0.11.0 bump (diff)
downloadgentoo-1827193fd9cfc6edb28e11981d4812dcf0fed59e.tar.gz
gentoo-1827193fd9cfc6edb28e11981d4812dcf0fed59e.tar.bz2
gentoo-1827193fd9cfc6edb28e11981d4812dcf0fed59e.zip
dev-python/neutron-lib: 1.25.0 bump
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python/neutron-lib/neutron-lib-1.25.0.ebuild')
-rw-r--r--dev-python/neutron-lib/neutron-lib-1.25.0.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/neutron-lib/neutron-lib-1.25.0.ebuild b/dev-python/neutron-lib/neutron-lib-1.25.0.ebuild
new file mode 100644
index 000000000000..87c8c64425de
--- /dev/null
+++ b/dev-python/neutron-lib/neutron-lib-1.25.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Neutron shared routines and utilities."
+HOMEPAGE="https://github.com/openstack/neutron-lib"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}"
+RDEPEND="${CDEPEND}
+ >=dev-python/sqlalchemy-1.2.0[${PYTHON_USEDEP}]
+ >=dev-python/pecan-1.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pecan-1.0.2[${PYTHON_USEDEP}]
+ !~dev-python/pecan-1.0.3[${PYTHON_USEDEP}]
+ !~dev-python/pecan-1.0.4[${PYTHON_USEDEP}]
+ !~dev-python/pecan-1.2.0[${PYTHON_USEDEP}]
+ >=dev-python/keystoneauth-3.4.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-concurrency-3.26.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-config-5.2.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-context-2.19.2[${PYTHON_USEDEP}]
+ >=dev-python/oslo-db-4.37.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
+ >=dev-python/oslo-log-3.36.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-messaging-5.29.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-policy-1.30.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-serialization-2.18.0[${PYTHON_USEDEP}]
+ !~dev-python/oslo-serialization-2.19.1[${PYTHON_USEDEP}]
+ >=dev-python/oslo-service-1.24.0[${PYTHON_USEDEP}]
+ !~dev-python/oslo-service-1.28.1[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-versionedobjects-1.31.2[${PYTHON_USEDEP}]
+ >=dev-python/osprofiler-1.4.0[${PYTHON_USEDEP}]
+ >=dev-python/setproctitle-1.1.10[${PYTHON_USEDEP}]
+ >=dev-python/weakrefmethod-1.0.2[$(python_gen_usedep 'python2_7')]
+ >=dev-python/os-traits-0.9.0[${PYTHON_USEDEP}]
+ >=dev-python/webob-1.7.1[${PYTHON_USEDEP}]"