summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-08-27 08:35:50 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2021-08-27 08:43:19 +0300
commit59ab91a0d90eb036c511223419ffb6d1246e1d89 (patch)
treeb3d45b1d8fe0407fe4b4529e322924c6b5477733 /dev-python/nnpy/nnpy-1.4.2.ebuild
parentdev-python/pytest-flakes: add 4.0.3, enable py3.10 (diff)
downloadgentoo-59ab91a0d90eb036c511223419ffb6d1246e1d89.tar.gz
gentoo-59ab91a0d90eb036c511223419ffb6d1246e1d89.tar.bz2
gentoo-59ab91a0d90eb036c511223419ffb6d1246e1d89.zip
dev-python/nnpy: enable py3.10
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/nnpy/nnpy-1.4.2.ebuild')
-rw-r--r--dev-python/nnpy/nnpy-1.4.2.ebuild11
1 files changed, 4 insertions, 7 deletions
diff --git a/dev-python/nnpy/nnpy-1.4.2.ebuild b/dev-python/nnpy/nnpy-1.4.2.ebuild
index 77862dd22ecd..443c714661da 100644
--- a/dev-python/nnpy/nnpy-1.4.2.ebuild
+++ b/dev-python/nnpy/nnpy-1.4.2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
@@ -14,7 +14,6 @@ SRC_URI="https://github.com/nanomsg/nnpy/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~arm"
-IUSE=""
DEPEND="
dev-python/cffi:=[${PYTHON_USEDEP}]
@@ -22,6 +21,4 @@ DEPEND="
"
RDEPEND="${DEPEND}"
-python_test() {
- PYTHONPATH="${S}:${PYTHONPATH}" "${PYTHON}" -m nnpy.tests || die
-}
+distutils_enable_tests unittest