summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-04-29 07:38:58 +0200
committerMichał Górny <mgorny@gentoo.org>2022-04-29 08:15:00 +0200
commite2a5ef4deaab198c3aa833f18ae245ad7fbbb614 (patch)
tree12d25fc836698cc20ffcbc12b409c9fa8b917185 /dev-python/node-semver/node-semver-0.8.1.ebuild
parentsys-devel/make: rebase patch paths (diff)
downloadgentoo-e2a5ef4deaab198c3aa833f18ae245ad7fbbb614.tar.gz
gentoo-e2a5ef4deaab198c3aa833f18ae245ad7fbbb614.tar.bz2
gentoo-e2a5ef4deaab198c3aa833f18ae245ad7fbbb614.zip
dev-python/node-semver: Bump to 0.8.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/node-semver/node-semver-0.8.1.ebuild')
-rw-r--r--dev-python/node-semver/node-semver-0.8.1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/node-semver/node-semver-0.8.1.ebuild b/dev-python/node-semver/node-semver-0.8.1.ebuild
new file mode 100644
index 000000000000..890c1dd273ad
--- /dev/null
+++ b/dev-python/node-semver/node-semver-0.8.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+
+inherit distutils-r1
+
+MY_P=python-${P}
+DESCRIPTION="Python version of node-semver, the semantic versioner for npm"
+HOMEPAGE="
+ https://pypi.org/project/node-semver/
+ https://github.com/podhmo/python-node-semver/
+ https://github.com/npm/node-semver/
+"
+SRC_URI="
+ https://github.com/podhmo/python-node-semver/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+distutils_enable_tests pytest