summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/nose-testconfig
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/nose-testconfig')
-rw-r--r--dev-python/nose-testconfig/Manifest1
-rw-r--r--dev-python/nose-testconfig/metadata.xml9
-rw-r--r--dev-python/nose-testconfig/nose-testconfig-0.9.ebuild26
3 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/nose-testconfig/Manifest b/dev-python/nose-testconfig/Manifest
new file mode 100644
index 000000000000..2fbcade6c6b6
--- /dev/null
+++ b/dev-python/nose-testconfig/Manifest
@@ -0,0 +1 @@
+DIST nose-testconfig-0.9.tar.gz 7614 SHA256 bb6f1dd2dbd3e54a6c456110fb6dced449b5ad5262af712d595c123e4f8c34d3 SHA512 411630f9af56955e5bd87efaf2db0817442f78dc61ea64a29ac186f0a71d23d81220f68bab18ceb7d3bf201bc441b522bf9acff21b541905a5a4397280444a07 WHIRLPOOL e69abb0eb794ed72f54010268a4eeb7356b374efa52caf60cc637a904836ca703b04d36bbbdbb6bc5eefaee6e7d1990cc7d52228864611c91ef631e09624a25b
diff --git a/dev-python/nose-testconfig/metadata.xml b/dev-python/nose-testconfig/metadata.xml
new file mode 100644
index 000000000000..651b8ab51417
--- /dev/null
+++ b/dev-python/nose-testconfig/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>openstack</herd>
+ <upstream>
+ <remote-id type="pypi">nose-testconfig</remote-id>
+ <remote-id type="bitbucket">jnoller/nose-testconfig</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/nose-testconfig/nose-testconfig-0.9.ebuild b/dev-python/nose-testconfig/nose-testconfig-0.9.ebuild
new file mode 100644
index 000000000000..cda3acab3c9d
--- /dev/null
+++ b/dev-python/nose-testconfig/nose-testconfig-0.9.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Test Configuration plugin for nosetests"
+HOMEPAGE="http://bitbucket.org/jnoller/nose-testconfig"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+RDEPEND="dev-python/nose"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+DOCS=( docs/index.txt )
+
+python_install_all() {
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}