summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-05-02 19:17:15 +0200
committerMichał Górny <mgorny@gentoo.org>2017-05-02 19:43:39 +0200
commit773e985801512269515c45c5c4a1da2988d62893 (patch)
tree6858badc41d89b3b5a1256e78de459fd08a3f874 /dev-python/nose_warnings_filters
parentdev-python/setproctitle: Clean old versions up (diff)
downloadgentoo-773e985801512269515c45c5c4a1da2988d62893.tar.gz
gentoo-773e985801512269515c45c5c4a1da2988d62893.tar.bz2
gentoo-773e985801512269515c45c5c4a1da2988d62893.zip
dev-python/nose_warnings_filters: Clean old versions up
Diffstat (limited to 'dev-python/nose_warnings_filters')
-rw-r--r--dev-python/nose_warnings_filters/Manifest2
-rw-r--r--dev-python/nose_warnings_filters/nose_warnings_filters-0.1.0.ebuild51
-rw-r--r--dev-python/nose_warnings_filters/nose_warnings_filters-0.1.1.ebuild51
3 files changed, 0 insertions, 104 deletions
diff --git a/dev-python/nose_warnings_filters/Manifest b/dev-python/nose_warnings_filters/Manifest
index cca382f14c17..d0b1efd0b077 100644
--- a/dev-python/nose_warnings_filters/Manifest
+++ b/dev-python/nose_warnings_filters/Manifest
@@ -1,3 +1 @@
-DIST nose_warnings_filters-0.1.0.tar.gz 3551 SHA256 198f1fb8d69583e555d565a544fb6817366d8493a783bbba6121a7c0adb8a7bb SHA512 6715d3a84fdaa712dfb10e4f48f874900e979dc58cbc8fdb4728a1589c9f0bec42b831e4896fb935b2ed4b2bde49e08210922ac3cda8fc0f18683b992f1b3dad WHIRLPOOL 1b1b65811e788eb27f67b2c7bbe8ee02a74dd53df8daa1af0d191cfdff8e9504d0885ede89657952d24b37a54bc193218ffa823071677e097040b0e7b32ac6cb
-DIST nose_warnings_filters-0.1.1.tar.gz 4118 SHA256 5d11dc351e6059cc398351140041377cffa1390097bc1564bdf325005163228c SHA512 fee5acff223077a8f5d753a7d01a77c0c3e2981bac8d4d8a847e1c81d363a945f0487a7237950dae9bd07fb3ee79c7404e512eba7e9987608baf70ec85bc684b WHIRLPOOL 2e826c01f70b9c7e4674fcd02fe1e7f129c5195d13cb55a76ca21d87dd032198599ca18a29d4b28cacef95b2f21c03282c31f7b58b9037b33680dd3e7a038477
DIST nose_warnings_filters-0.1.5.tar.gz 3895 SHA256 456c5b2ccca24e1d00a7b558274ebf9318305813dcb9585951a73ae11d76bb9d SHA512 7ada463840bb2e3a1c7e357c231f9c7d4c7ce9f24fe7fe1e33404df41711663c8232001f9a258898f49ce89bb542a942240cf7312ee41bc75f86ca2015378405 WHIRLPOOL bff4646af7733229ecfd2b1926aa9036b4ea2b3d219493bcb3a1f1155bab1dc1c064a9a19a6f1ee4c608eaaa118fbba9ff286f9d915a591e7d1fc7ea2536569b
diff --git a/dev-python/nose_warnings_filters/nose_warnings_filters-0.1.0.ebuild b/dev-python/nose_warnings_filters/nose_warnings_filters-0.1.0.ebuild
deleted file mode 100644
index ffdc6682fe5f..000000000000
--- a/dev-python/nose_warnings_filters/nose_warnings_filters-0.1.0.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python{2_7,3_4,3_5} )
-
-inherit python-r1
-
-DESCRIPTION="A python module to inject warning filters during nosetest"
-HOMEPAGE="https://github.com/Carreau/nose_warnings_filters"
-SRC_URI="https://github.com/Carreau/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-DEPEND="${PYTHON_DEPS}
- dev-python/nose[${PYTHON_USEDEP}]"
-RDEPEND="${DEPEND}"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-src_test() {
- # nose_warnings_filters doesn't have a proper
- # testing suite, hence we run the only testing
- # script available
- export PYTHONPATH="${S}:${S}/${PN}/tests"
- touch "${S}/${PN}/tests/__init__.py" || die
- run_test() {
- "${PYTHON}" "${PN}"/tests/test_config.py \
- || die "Failed running test script"
- }
- python_foreach_impl run_test
- unset PYTHONPATH
-}
-
-src_install() {
- python_moduleinto "${PN}"
- install_files() {
- python_domodule "${PN}/__init__.py"
-
- # Unfortunately, nose_warnings_filters is designed
- # as a wheel package, for which a METADATA file is
- # strictly required, otherwise a Runtime error is thrown
- local egg_dir="${D%/}$(python_get_sitedir)/${PN}-${PV}.dist-info"
- mkdir -p "${egg_dir}" || die
- cp entry_points.txt "${egg_dir}" || die
- touch "${egg_dir}"/METADATA || die
- }
- python_foreach_impl install_files
-}
diff --git a/dev-python/nose_warnings_filters/nose_warnings_filters-0.1.1.ebuild b/dev-python/nose_warnings_filters/nose_warnings_filters-0.1.1.ebuild
deleted file mode 100644
index ffdc6682fe5f..000000000000
--- a/dev-python/nose_warnings_filters/nose_warnings_filters-0.1.1.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python{2_7,3_4,3_5} )
-
-inherit python-r1
-
-DESCRIPTION="A python module to inject warning filters during nosetest"
-HOMEPAGE="https://github.com/Carreau/nose_warnings_filters"
-SRC_URI="https://github.com/Carreau/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-DEPEND="${PYTHON_DEPS}
- dev-python/nose[${PYTHON_USEDEP}]"
-RDEPEND="${DEPEND}"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-src_test() {
- # nose_warnings_filters doesn't have a proper
- # testing suite, hence we run the only testing
- # script available
- export PYTHONPATH="${S}:${S}/${PN}/tests"
- touch "${S}/${PN}/tests/__init__.py" || die
- run_test() {
- "${PYTHON}" "${PN}"/tests/test_config.py \
- || die "Failed running test script"
- }
- python_foreach_impl run_test
- unset PYTHONPATH
-}
-
-src_install() {
- python_moduleinto "${PN}"
- install_files() {
- python_domodule "${PN}/__init__.py"
-
- # Unfortunately, nose_warnings_filters is designed
- # as a wheel package, for which a METADATA file is
- # strictly required, otherwise a Runtime error is thrown
- local egg_dir="${D%/}$(python_get_sitedir)/${PN}-${PV}.dist-info"
- mkdir -p "${egg_dir}" || die
- cp entry_points.txt "${egg_dir}" || die
- touch "${egg_dir}"/METADATA || die
- }
- python_foreach_impl install_files
-}