summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2019-10-13 16:13:52 -0400
committerCraig Andrews <candrews@gentoo.org>2019-10-15 11:57:54 -0400
commit56ce206f30259ee64505f2e324d496071a292c82 (patch)
treeef207d0dc3a8ab009fd4fc1eab09456e3df1bdcf /dev-python/nosexcover
parentdev-python/nosexcover: Python 3.7 compatibility (diff)
downloadgentoo-56ce206f30259ee64505f2e324d496071a292c82.tar.gz
gentoo-56ce206f30259ee64505f2e324d496071a292c82.tar.bz2
gentoo-56ce206f30259ee64505f2e324d496071a292c82.zip
dev-python/nosexcover: EAPI=7
Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'dev-python/nosexcover')
-rw-r--r--dev-python/nosexcover/nosexcover-1.0.11-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/nosexcover/nosexcover-1.0.11-r1.ebuild b/dev-python/nosexcover/nosexcover-1.0.11-r1.ebuild
new file mode 100644
index 000000000000..361675192710
--- /dev/null
+++ b/dev-python/nosexcover/nosexcover-1.0.11-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Extends nose.plugins.cover to add Cobertura-style XML reports"
+HOMEPAGE="https://github.com/cmheisel/nose-xcover/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE=""
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ >=dev-python/coverage-3.4[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+python_test() {
+ nosetests -v nosexcover/tests.py || die
+}