summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-03-23 00:16:37 +0100
committerMichał Górny <mgorny@gentoo.org>2021-03-23 00:53:16 +0100
commit370a505a4a4c48645cbb1d911446190fcc1a4c23 (patch)
treed5c0980b559c161d0b7de31134387587c1fc04ea /dev-python/notebook
parentdev-python/notebook: Disable selenium tests harder (diff)
downloadgentoo-370a505a4a4c48645cbb1d911446190fcc1a4c23.tar.gz
gentoo-370a505a4a4c48645cbb1d911446190fcc1a4c23.tar.bz2
gentoo-370a505a4a4c48645cbb1d911446190fcc1a4c23.zip
dev-python/notebook: Add xdg postinst/postrm
Closes: https://bugs.gentoo.org/777798 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/notebook')
-rw-r--r--dev-python/notebook/notebook-6.3.0.ebuild12
1 files changed, 11 insertions, 1 deletions
diff --git a/dev-python/notebook/notebook-6.3.0.ebuild b/dev-python/notebook/notebook-6.3.0.ebuild
index 79f3213aac14..9de1aeb1b611 100644
--- a/dev-python/notebook/notebook-6.3.0.ebuild
+++ b/dev-python/notebook/notebook-6.3.0.ebuild
@@ -7,7 +7,7 @@ DISTUTILS_USE_SETUPTOOLS=rdepend
PYTHON_COMPAT=( python3_{7..9} )
PYTHON_REQ_USE="threads(+)"
-inherit distutils-r1
+inherit distutils-r1 xdg-utils
DESCRIPTION="Jupyter Interactive Notebook"
HOMEPAGE="https://jupyter.org"
@@ -87,3 +87,13 @@ pkg_preinst() {
# remove old mathjax folder if present
rm -rf "${EROOT}"/usr/lib*/python*/site-packages/notebook/static/components/MathJax || die
}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}