summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Brehler <marbre@linux.sungazer.de>2017-02-03 11:45:13 +0100
committerDavid Seifert <soap@gentoo.org>2017-02-04 22:27:46 +0100
commit5cc465662f1c92fbece1ece4250829999caf656e (patch)
tree5fda386bc88a06ed3862540954357026319d4971 /dev-python/notebook
parentprofiles: consolidate desktop mpv USE flags in one place (diff)
downloadgentoo-5cc465662f1c92fbece1ece4250829999caf656e.tar.gz
gentoo-5cc465662f1c92fbece1ece4250829999caf656e.tar.bz2
gentoo-5cc465662f1c92fbece1ece4250829999caf656e.zip
dev-python/notebook: Version bump to 4.3.2
Package-Manager: portage-2.3.3 Closes: https://github.com/gentoo/gentoo/pull/3785
Diffstat (limited to 'dev-python/notebook')
-rw-r--r--dev-python/notebook/Manifest1
-rw-r--r--dev-python/notebook/notebook-4.3.2.ebuild92
2 files changed, 93 insertions, 0 deletions
diff --git a/dev-python/notebook/Manifest b/dev-python/notebook/Manifest
index a8fb1c12358d..d710726b97a3 100644
--- a/dev-python/notebook/Manifest
+++ b/dev-python/notebook/Manifest
@@ -2,3 +2,4 @@ DIST notebook-4.0.6.tar.gz 6705277 SHA256 f62e7a6afbc00bab3615b927595d27b1874cff
DIST notebook-4.1.0.tar.gz 9170981 SHA256 b597437ba33538221008e21fea71cd01eda9da1515ca3963d7c74e44f4b03d90 SHA512 745e412a737835956dc4238f70dbaf9c519fea55988941174febdc3ad24962031c3c66cb4ac355a9a639f9a383905e863e8eb0a3c6da62bf72026282154874cb WHIRLPOOL a34501e8e0be300905628e0f0df6914e8491a00924150ff0f5f32d1b7ad99046b84958dc267a229797fb13c98085f7556496a1a8e5fb68a1db503b44cad2b380
DIST notebook-4.2.3.tar.gz 10092423 SHA256 39a9603d3fe88b60de2903680c965cf643acf2c16fb2c6bac1d905e1042b5851 SHA512 1b54e2a16fdb79b9344c0f73bd48fe438b18c529707b15816a3ab20353b2e320067082d51829c670117d77830a21c5a64a15d37d1970fd30aae31272d9650d97 WHIRLPOOL 9cbcfc80dd818c77f1db5226b729e576f7428184001747eda8780c70b3cfb6b9472b8760073e2891ee40bc90e0398e88250b02c8c2eb6b7c2517fa6eecf2ceba
DIST notebook-4.3.0.tar.gz 10271381 SHA256 c0d9beb94d7dc4958ec6cc76966c9b63f89092a03823365ae9e2930d38faa7da SHA512 dfbaf022b988b1fe3102dd094243b6ebc8fe9910299ed5b12c0292ff1c1b6ee1b20df0578c4fea47a1f9dfb031a7b329f5ea2684ec6019b49568536c7fa5a532 WHIRLPOOL 099b4354a8444091a880770f21861f1407fdd368253a9418e7833025897a65516d00efac45af17248446739be8661dbd4842169963a38dd3d446431e95846855
+DIST notebook-4.3.2.tar.gz 10375345 SHA256 fc77edf4ec295542172aa66a3e9d527e75038fcaadd3ed20afbf8596e5629aa9 SHA512 8ff9a4852aafbc2761e82cd1cbacfc85dade97ec58386df55eea1e97f513b3d608106a2cc43305968fd990974daf6c8dac8aab4ab2184c56976289e646a62b7b WHIRLPOOL 4921242a8cfe316e835b88879cbc9cd41abff39daaf6f8e5d373609f3cd64f286052041bcc9e496b5a570dc9126892a1163dfef6df1b037f6ed92f101d8c74d5
diff --git a/dev-python/notebook/notebook-4.3.2.ebuild b/dev-python/notebook/notebook-4.3.2.ebuild
new file mode 100644
index 000000000000..5947d4245fef
--- /dev/null
+++ b/dev-python/notebook/notebook-4.3.2.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Jupyter Interactive Notebook"
+HOMEPAGE="http://jupyter.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+RDEPEND="
+ >=dev-libs/mathjax-2.4
+ dev-python/jinja[${PYTHON_USEDEP}]
+ >=dev-python/terminado-0.3.3[${PYTHON_USEDEP}]
+ >=www-servers/tornado-4.0[${PYTHON_USEDEP}]
+ dev-python/ipython_genutils[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-4.2.1[${PYTHON_USEDEP}]
+ dev-python/jupyter_core[${PYTHON_USEDEP}]
+ dev-python/jupyter_client[${PYTHON_USEDEP}]
+ dev-python/nbformat[${PYTHON_USEDEP}]
+ >=dev-python/nbconvert-4.2.0[${PYTHON_USEDEP}]
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ "
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' 'python2*')
+ >=dev-python/nose-0.10.1[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}]
+ )
+ doc? (
+ app-text/pandoc
+ >=dev-python/ipython-4.0.0[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.1[${PYTHON_USEDEP}]
+ )
+ "
+
+PATCHES=( "${FILESDIR}/${PN}"-4.2.0-setupbase.py.patch )
+
+python_prepare_all() {
+ sed \
+ -e "/import setup/s:$:\nimport setuptools:g" \
+ -i setup.py || die
+
+ # disable bundled mathjax
+ sed -i 's/^.*MathJax.*$//' bower.json || die
+
+ # Prevent un-needed download during build
+ if use doc; then
+ sed \
+ -e "/^ 'sphinx.ext.intersphinx',/d" \
+ -i docs/source/conf.py || die
+ fi
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ if use doc; then
+ emake -C docs html
+ HTML_DOCS=( docs/build/html/. )
+ fi
+}
+
+python_test() {
+ nosetests \
+ --verbosity=3 \
+ notebook || die
+}
+
+python_install() {
+ distutils-r1_python_install
+
+ ln -sf \
+ "${EPREFIX}/usr/share/mathjax" \
+ "${D}$(python_get_sitedir)/notebook/static/components/MathJax" || die
+}
+
+pkg_preinst() {
+ # remove old mathjax folder if present
+ rm -rf "${EROOT%/}"/usr/lib*/python*/site-packages/notebook/static/components/MathJax || die
+}