summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-12-17 17:57:49 +0100
committerMichał Górny <mgorny@gentoo.org>2020-12-17 18:09:22 +0100
commiteaad9dee11d80c6267a044d59afdcd6b9219d36e (patch)
tree3da3cacbed0d2fe8434081ca22fb0ad4ce2097a7 /dev-python/notebook
parentdev-python/graphviz: Remove old (diff)
downloadgentoo-eaad9dee11d80c6267a044d59afdcd6b9219d36e.tar.gz
gentoo-eaad9dee11d80c6267a044d59afdcd6b9219d36e.tar.bz2
gentoo-eaad9dee11d80c6267a044d59afdcd6b9219d36e.zip
dev-python/notebook: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/notebook')
-rw-r--r--dev-python/notebook/Manifest1
-rw-r--r--dev-python/notebook/notebook-6.1.4.ebuild93
2 files changed, 0 insertions, 94 deletions
diff --git a/dev-python/notebook/Manifest b/dev-python/notebook/Manifest
index 1f5f605ff0ef..d096043b8a3f 100644
--- a/dev-python/notebook/Manifest
+++ b/dev-python/notebook/Manifest
@@ -1,3 +1,2 @@
DIST notebook-6.1.3.tar.gz 13806042 BLAKE2B da63fdabd1a71e4247a9e340539e688410a84c58d94049dfb7e8e3fcdc53686a55eb855687df34ff48f599a0c5aececbd9a8e1aa1d2ff7baa2a6da1b4e1bcf24 SHA512 67a8feb01dfb665bb24f3ce1b28212e9bad5a188e8cef1d168c4edaf207cbc16d516f6024ca905f75f1c27ba4890da858c5278a3ee84a4c4ac1bdbf225afa351
-DIST notebook-6.1.4.tar.gz 13933373 BLAKE2B 9e58a9913a3c24bb1cb364863a18993d44496e995dc43dc9a4b428c54a0dddcc8b7c4b444073029d97705f0b3eee37d63bb50eec066b9b5fe4cd0ee48f8df558 SHA512 55637ec76b283429ac8bc1de260529983cf0e4cb0f25b268330fcc1d07c6e75329d2806eaa5f10d149bf80bd11df26592fa71548fa03bdb05a57265221466b57
DIST notebook-6.1.5.tar.gz 13925632 BLAKE2B ce9d0ee110a158ba0ee3f3199a7cc1c8d53ecb72e8f77f43d2b1e5552b4a0378edca9a987634e12d8429c70595ec4cc226784248d196501b3a04c67e4ba88c85 SHA512 4b0893c805a0494c369b363b7d1c606a1b124869e601eafce1eb4c93ad1436b757c6149bc76c489aa26171412280d69e894b44d7d19141341fb1194a8e2f447b
diff --git a/dev-python/notebook/notebook-6.1.4.ebuild b/dev-python/notebook/notebook-6.1.4.ebuild
deleted file mode 100644
index a484e7f04afd..000000000000
--- a/dev-python/notebook/notebook-6.1.4.ebuild
+++ /dev/null
@@ -1,93 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DISTUTILS_USE_SETUPTOOLS=rdepend
-PYTHON_COMPAT=( python3_{7..9} )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1
-
-DESCRIPTION="Jupyter Interactive Notebook"
-HOMEPAGE="https://jupyter.org"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 x86"
-
-RDEPEND="
- >=dev-libs/mathjax-2.4
- dev-python/argon2-cffi[${PYTHON_USEDEP}]
- dev-python/jinja[${PYTHON_USEDEP}]
- >=dev-python/terminado-0.8.3[${PYTHON_USEDEP}]
- >=www-servers/tornado-5.0[${PYTHON_USEDEP}]
- dev-python/ipython_genutils[${PYTHON_USEDEP}]
- >=dev-python/traitlets-4.2.1[${PYTHON_USEDEP}]
- >=dev-python/jupyter_core-4.6.1[${PYTHON_USEDEP}]
- >=dev-python/pyzmq-17[${PYTHON_USEDEP}]
- >=dev-python/jupyter_client-5.3.4[${PYTHON_USEDEP}]
- dev-python/nbformat[${PYTHON_USEDEP}]
- >=dev-python/nbconvert-4.2.0[${PYTHON_USEDEP}]
- dev-python/ipykernel[${PYTHON_USEDEP}]
- dev-python/send2trash[${PYTHON_USEDEP}]
- dev-python/prometheus_client[${PYTHON_USEDEP}]"
-
-# sphinx 2+ seems to have a problem with its github plugin. temporarily adding
-# a version constraint.
-BDEPEND="
- test? (
- dev-python/nose[${PYTHON_USEDEP}]
- dev-python/nose_warnings_filters[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/requests-unixsocket[${PYTHON_USEDEP}]
- )
- "
-
-PATCHES=(
- "${FILESDIR}/${PN}"-5.7.0-no-mathjax.patch
-)
-
-distutils_enable_tests pytest
-
-python_prepare_all() {
- # disable bundled mathjax
- sed -i 's/^.*MathJax.*$//' bower.json || die
-
- # require geckodriver
- rm -r notebook/tests/selenium || die
- # trash doesn't seem to work for us
- sed -e 's:test_delete:_&:' \
- -i notebook/services/contents/tests/test_manager.py || die
- sed -e 's:test_checkpoints_follow_file:_&:' \
- -e 's:test_delete:_&:' \
- -i notebook/services/contents/tests/test_contents_api.py || die
- # network-sandbox?
- sed -e 's:test_connections:_&:' \
- -e 's:test_culling:_&:' \
- -i notebook/services/kernels/tests/test_kernels_api.py || die
-
- sed -i -e "/'bdist_egg':/d" setup.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- distutils_install_for_testing
- local -x PATH=${TEST_DIR}/scripts:${PATH}
- pytest -vv || die "Tests failed with ${EPYTHON}"
-}
-
-python_install() {
- distutils-r1_python_install
-
- ln -sf \
- "${EPREFIX}/usr/share/mathjax" \
- "${D}$(python_get_sitedir)/notebook/static/components/MathJax" || die
-}
-
-pkg_preinst() {
- # remove old mathjax folder if present
- rm -rf "${EROOT}"/usr/lib*/python*/site-packages/notebook/static/components/MathJax || die
-}