summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Pielmeier <billie@gentoo.org>2019-09-05 19:08:52 +0200
committerDaniel Pielmeier <billie@gentoo.org>2019-09-05 19:08:52 +0200
commit8a851ac679b26f6b77d28c347f849eadcb215131 (patch)
treec92ea7460d02f7d593854ce400f71cfdf26a5c9f /dev-python/notify2/notify2-0.3.1-r1.ebuild
parentkde-misc/latte-dock: 0.9.2 version bump (diff)
downloadgentoo-8a851ac679b26f6b77d28c347f849eadcb215131.tar.gz
gentoo-8a851ac679b26f6b77d28c347f849eadcb215131.tar.bz2
gentoo-8a851ac679b26f6b77d28c347f849eadcb215131.zip
dev-python/notify2: Revision bump to notify2-0.3.1-r1.
Add support for python-3.7. This fixes bug #693560. Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Daniel Pielmeier <billie@gentoo.org>
Diffstat (limited to 'dev-python/notify2/notify2-0.3.1-r1.ebuild')
-rw-r--r--dev-python/notify2/notify2-0.3.1-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/notify2/notify2-0.3.1-r1.ebuild b/dev-python/notify2/notify2-0.3.1-r1.ebuild
new file mode 100644
index 000000000000..d04e66c02b35
--- /dev/null
+++ b/dev-python/notify2/notify2-0.3.1-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Python interface to DBus notifications."
+HOMEPAGE="https://bitbucket.org/takluyver/pynotify2"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE="examples"
+
+RDEPEND="dev-python/dbus-python[${PYTHON_USEDEP}]"
+
+python_test() {
+ virtx ${EPYTHON} test_notify2.py || die
+}
+
+python_install_all() {
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/*
+ fi
+ distutils-r1_python_install_all
+}