summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-05-08 11:26:57 +0200
committerMichał Górny <mgorny@gentoo.org>2024-05-08 11:26:57 +0200
commita57c84a1388d0d992e116cadaca49c7d1b0cac3e (patch)
treed2c015d18426b64a1899f0c871a75713ac42224b /dev-python/nspektr/nspektr-0.5.0.ebuild
parentapp-portage/mgorny-dev-scripts: Bump to 52 (diff)
downloadgentoo-a57c84a1388d0d992e116cadaca49c7d1b0cac3e.tar.gz
gentoo-a57c84a1388d0d992e116cadaca49c7d1b0cac3e.tar.bz2
gentoo-a57c84a1388d0d992e116cadaca49c7d1b0cac3e.zip
dev-python/nspektr: Remove last-rited pkg
Bug: https://bugs.gentoo.org/928270 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/nspektr/nspektr-0.5.0.ebuild')
-rw-r--r--dev-python/nspektr/nspektr-0.5.0.ebuild54
1 files changed, 0 insertions, 54 deletions
diff --git a/dev-python/nspektr/nspektr-0.5.0.ebuild b/dev-python/nspektr/nspektr-0.5.0.ebuild
deleted file mode 100644
index c48603b4592f..000000000000
--- a/dev-python/nspektr/nspektr-0.5.0.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 2022-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-# please keep this ebuild at EAPI 7 -- sys-apps/portage dep
-EAPI=7
-
-DISTUTILS_USE_PEP517=flit
-PYTHON_COMPAT=( pypy3 python3_{10..12} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Distribution package dependency inspector"
-HOMEPAGE="
- https://github.com/jaraco/nspektr/
- https://pypi.org/project/nspektr/
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
-
-RDEPEND="
- >=dev-python/jaraco-context-4.1.1-r2[${PYTHON_USEDEP}]
- >=dev-python/jaraco-functools-3.5.0-r2[${PYTHON_USEDEP}]
- >=dev-python/more-itertools-8.12.0-r1[${PYTHON_USEDEP}]
- >=dev-python/packaging-21.3-r2[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests pytest
-
-src_configure() {
- grep -q 'build-backend = "setuptools' pyproject.toml ||
- die "Upstream changed build-backend, recheck"
- # write a custom pyproject.toml to ease setuptools bootstrap
- cat > pyproject.toml <<-EOF || die
- [build-system]
- requires = ["flit_core >=3.2,<4"]
- build-backend = "flit_core.buildapi"
-
- [project]
- name = "nspektr"
- version = "${PV}"
- description = "package inspector"
-
- # tests inspect itself
- [project.optional-dependencies]
- docs = [
- "fake-nonexisting",
- ]
- testing = [
- "pytest",
- ]
- EOF
-}