summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-01-12 12:13:33 +0100
committerMichał Górny <mgorny@gentoo.org>2020-01-12 12:25:10 +0100
commit084f5a3b0336767dd71e40105cc78652b4cb892a (patch)
treed3c476c66e340e436fddd6b7cc5f2946d50d23c1 /dev-python/ntlm-auth/ntlm-auth-1.4.0-r1.ebuild
parentgames-strategy/dunelegacy: Don't patch configure.ac unnecessarily (diff)
downloadgentoo-084f5a3b0336767dd71e40105cc78652b4cb892a.tar.gz
gentoo-084f5a3b0336767dd71e40105cc78652b4cb892a.tar.bz2
gentoo-084f5a3b0336767dd71e40105cc78652b4cb892a.zip
dev-python/ntlm-auth: Remove mistaken dep on ordereddict
This package needs ordereddict for Python < 2.7, not 2.7 itself. Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/ntlm-auth/ntlm-auth-1.4.0-r1.ebuild')
-rw-r--r--dev-python/ntlm-auth/ntlm-auth-1.4.0-r1.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/ntlm-auth/ntlm-auth-1.4.0-r1.ebuild b/dev-python/ntlm-auth/ntlm-auth-1.4.0-r1.ebuild
new file mode 100644
index 000000000000..f34de2bf8fea
--- /dev/null
+++ b/dev-python/ntlm-auth/ntlm-auth-1.4.0-r1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Calculates NTLM Authentication codes"
+HOMEPAGE="https://github.com/jborean93/ntlm-auth"
+SRC_URI="https://github.com/jborean93/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"