summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-06-23 21:43:24 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-06-23 22:28:21 +0300
commit078f93143cd39cf8d7368b89465e34d2c0c28434 (patch)
tree6e0c56332c989be893adbd2c6c3093baf78570e6 /dev-python/nuitka
parentdev-python/oslo-utils: add 6.0.0 (diff)
downloadgentoo-078f93143cd39cf8d7368b89465e34d2c0c28434.tar.gz
gentoo-078f93143cd39cf8d7368b89465e34d2c0c28434.tar.bz2
gentoo-078f93143cd39cf8d7368b89465e34d2c0c28434.zip
dev-python/nuitka: add 0.9
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/nuitka')
-rw-r--r--dev-python/nuitka/Manifest1
-rw-r--r--dev-python/nuitka/nuitka-0.9.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/nuitka/Manifest b/dev-python/nuitka/Manifest
index abbd087e1bd3..59a5623cccf4 100644
--- a/dev-python/nuitka/Manifest
+++ b/dev-python/nuitka/Manifest
@@ -1 +1,2 @@
DIST Nuitka-0.8.4.tar.gz 3828278 BLAKE2B dbd6abb945f66ab6a5a359b8370fd3d5d36fbdc2c232b5002356f59ffbfa531180b96467b67a2edbb7a779c75ebe58789e9ae0ff806b5649eea4a5b7d9c0934c SHA512 683918e60f2f65d22911f894c2e4fedeafd9d0ef0cacd48bb66422fa2077f225c7c861186b83b9c0fd50eb965b956a1b26342249b3db2af599250c16fe84a152
+DIST Nuitka-0.9.tar.gz 3855240 BLAKE2B 59a508aabb04af0b841879a4de23fe9f9f8ea2588125127834319da21ef22ab530d8e39a2baba1b49043e9997dff9a20004fc548af5b09456b5eb3cd8f1d30a8 SHA512 ae2903e89233b7944e1ee1aa846897d30c352302bb8b064a31ab69237dc15ed0e451bba63db5530968e10f60b8da745bf7d7f1f130ff039d9aac2329f628f32f
diff --git a/dev-python/nuitka/nuitka-0.9.ebuild b/dev-python/nuitka/nuitka-0.9.ebuild
new file mode 100644
index 000000000000..5b987e13729d
--- /dev/null
+++ b/dev-python/nuitka/nuitka-0.9.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1 flag-o-matic optfeature
+
+DESCRIPTION="Python to native compiler"
+HOMEPAGE="https://www.nuitka.net"
+SRC_URI="https://nuitka.net/releases/${P^}.tar.gz"
+S="${WORKDIR}/${P^}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~loong ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-util/scons[${PYTHON_USEDEP}]"
+BDEPEND="
+ ${RDEPEND}
+ test? ( dev-util/ccache )
+"
+
+DOCS=( Changelog.pdf Developer_Manual.pdf README.pdf )
+
+distutils-r1_src_prepare() {
+ # remove vendored version of SCons that is Python2 only
+ # this should be removed when upstream removes support for Python2
+ rm -vR "${PN}/build/inline_copy/lib/scons-2.3.2/SCons" || die
+ eapply_user
+}
+
+python_install() {
+ distutils-r1_python_install
+ doman doc/nuitka3.1 doc/nuitka3-run.1
+}
+
+python_test() {
+ append-ldflags -Wl,--no-warn-search-mismatch
+ ./tests/basics/run_all.py search || die
+}
+
+pkg_postinst() {
+ optfeature "support for stand-alone executables" app-admin/chrpath
+}