summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-21 07:39:25 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-21 08:47:05 +0200
commit1f624963450c6a8a1a2f088aeb4b8d626f490b5e (patch)
treed5589e91751b7be28b570e1e99d4d3ff8e7451fd /dev-python/nuitka
parentdev-python/cloudpickle: Bump to 2.1.0 (diff)
downloadgentoo-1f624963450c6a8a1a2f088aeb4b8d626f490b5e.tar.gz
gentoo-1f624963450c6a8a1a2f088aeb4b8d626f490b5e.tar.bz2
gentoo-1f624963450c6a8a1a2f088aeb4b8d626f490b5e.zip
dev-python/nuitka: Bump to 0.8
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/nuitka')
-rw-r--r--dev-python/nuitka/Manifest1
-rw-r--r--dev-python/nuitka/nuitka-0.8.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/nuitka/Manifest b/dev-python/nuitka/Manifest
index c817c6eb6639..1dc7ac77f495 100644
--- a/dev-python/nuitka/Manifest
+++ b/dev-python/nuitka/Manifest
@@ -1 +1,2 @@
DIST Nuitka-0.7.7.tar.gz 3785340 BLAKE2B e856bcb3ecf69ecaa447ea73219f544bfceae8ee3a480fbd13b0a763efb8c8ec3c856a6142cff6a91273a88fc0aec15a6bb6c28fab1d9ca0c4dfeca229c11b68 SHA512 124e2d405b1104d0ba42a69b20a5c6168bb0643a13a4de789279401e09c30091853a8e464d9c4877a01f93a5a63934617cf52678994d0ae179560cd21d5b196e
+DIST Nuitka-0.8.tar.gz 3829530 BLAKE2B 051be63639e491fb26e7ef36b7e034715d0dd0e39417b59c30b0c5628e78d6c655978a2198d7192b431f176a24060fa899fb9c17ff6dc02fedb64865ad37af5a SHA512 f4eef21a32b68d52363ede1f68afa0247bf61a142fc86763f28805ca3a611195bb87bd1229a31a4d0ce47bbae7f70cc18580ebab528772f0908f122d8341bc6c
diff --git a/dev-python/nuitka/nuitka-0.8.ebuild b/dev-python/nuitka/nuitka-0.8.ebuild
new file mode 100644
index 000000000000..5b987e13729d
--- /dev/null
+++ b/dev-python/nuitka/nuitka-0.8.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1 flag-o-matic optfeature
+
+DESCRIPTION="Python to native compiler"
+HOMEPAGE="https://www.nuitka.net"
+SRC_URI="https://nuitka.net/releases/${P^}.tar.gz"
+S="${WORKDIR}/${P^}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~loong ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-util/scons[${PYTHON_USEDEP}]"
+BDEPEND="
+ ${RDEPEND}
+ test? ( dev-util/ccache )
+"
+
+DOCS=( Changelog.pdf Developer_Manual.pdf README.pdf )
+
+distutils-r1_src_prepare() {
+ # remove vendored version of SCons that is Python2 only
+ # this should be removed when upstream removes support for Python2
+ rm -vR "${PN}/build/inline_copy/lib/scons-2.3.2/SCons" || die
+ eapply_user
+}
+
+python_install() {
+ distutils-r1_python_install
+ doman doc/nuitka3.1 doc/nuitka3-run.1
+}
+
+python_test() {
+ append-ldflags -Wl,--no-warn-search-mismatch
+ ./tests/basics/run_all.py search || die
+}
+
+pkg_postinst() {
+ optfeature "support for stand-alone executables" app-admin/chrpath
+}