summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-10-21 07:22:02 +0200
committerMichał Górny <mgorny@gentoo.org>2022-10-21 09:48:12 +0200
commitbb4a555737f950b5db8ff3fbe09638a820064a06 (patch)
treec429f7e9ce78d66cf1d4e8100594c296e760718e /dev-python/nuitka
parentdev-python/nuitka: Remove old (diff)
downloadgentoo-bb4a555737f950b5db8ff3fbe09638a820064a06.tar.gz
gentoo-bb4a555737f950b5db8ff3fbe09638a820064a06.tar.bz2
gentoo-bb4a555737f950b5db8ff3fbe09638a820064a06.zip
dev-python/nuitka: Bump to 1.1.6
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/nuitka')
-rw-r--r--dev-python/nuitka/Manifest1
-rw-r--r--dev-python/nuitka/nuitka-1.1.6.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/nuitka/Manifest b/dev-python/nuitka/Manifest
index 1251af3cc1fc..63d184e666f0 100644
--- a/dev-python/nuitka/Manifest
+++ b/dev-python/nuitka/Manifest
@@ -1 +1,2 @@
DIST Nuitka-1.1.5.tar.gz 3920916 BLAKE2B 7352009df91e39c63073e8230065af990c86d07cf51752ceaf234e4e8b5814d085ee7423440dc5bb8ca63341f7e1eccdbd41631711ebcfac481bcb3645c011f2 SHA512 ef88b98341cb930529d6e31bb487cf3bb8c217dd9b8a8b50c8e5b147f0b4879a17f2d6c7621a056ad3f1ffd15ac88781445bc0dc8dc164a38aea83b43a6bf3c7
+DIST Nuitka-1.1.6.tar.gz 3923364 BLAKE2B 680496486121ff17bb8bded93ea3be79c65cc7d1eb8352a29699e3f0c9f6cec75c83f1018b58f837dc181668cb3d5f7574f8c6ded80d9727c396d5caad2896a2 SHA512 8bdf4ed2bf15ff0d5ab88f3df151c219822a718d7c5244075ffef1822467861030875fa508eb861825fab030232f041f0baf7e719eba0f82ae1d9ace224eb749
diff --git a/dev-python/nuitka/nuitka-1.1.6.ebuild b/dev-python/nuitka/nuitka-1.1.6.ebuild
new file mode 100644
index 000000000000..b55f0385d58a
--- /dev/null
+++ b/dev-python/nuitka/nuitka-1.1.6.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1 flag-o-matic optfeature
+
+DESCRIPTION="Python to native compiler"
+HOMEPAGE="
+ https://www.nuitka.net/
+ https://github.com/Nuitka/Nuitka/
+ https://pypi.org/project/Nuitka/
+"
+SRC_URI="https://nuitka.net/releases/${P^}.tar.gz"
+S=${WORKDIR}/${P^}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~loong ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-util/scons[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ ${RDEPEND}
+ test? ( dev-util/ccache )
+"
+
+DOCS=( Changelog.pdf Developer_Manual.pdf README.pdf )
+
+distutils-r1_src_prepare() {
+ # remove vendored version of SCons that is Python2 only
+ # this should be removed when upstream removes support for Python2
+ rm -vR "${PN}/build/inline_copy/lib/scons-2.3.2/SCons" || die
+ eapply_user
+}
+
+python_install() {
+ distutils-r1_python_install
+ doman doc/nuitka3.1 doc/nuitka3-run.1
+}
+
+python_test() {
+ append-ldflags -Wl,--no-warn-search-mismatch
+ ./tests/basics/run_all.py search || die
+}
+
+pkg_postinst() {
+ optfeature "support for stand-alone executables" app-admin/chrpath
+}