summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVirgil Dupras <vdupras@gentoo.org>2019-02-20 16:10:21 -0500
committerVirgil Dupras <vdupras@gentoo.org>2019-02-20 16:10:21 -0500
commit3fa927ddff6bbec95718ea6e7dc578ac17e9c92a (patch)
tree29b4624c9101c4fea696e18d45cf31d86c39c34b /dev-python/numexpr
parentdev-python/numexpr: bump to 2.6.9 (diff)
downloadgentoo-3fa927ddff6bbec95718ea6e7dc578ac17e9c92a.tar.gz
gentoo-3fa927ddff6bbec95718ea6e7dc578ac17e9c92a.tar.bz2
gentoo-3fa927ddff6bbec95718ea6e7dc578ac17e9c92a.zip
dev-python/numexpr: remove old
Signed-off-by: Virgil Dupras <vdupras@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'dev-python/numexpr')
-rw-r--r--dev-python/numexpr/Manifest2
-rw-r--r--dev-python/numexpr/numexpr-2.6.1.ebuild58
-rw-r--r--dev-python/numexpr/numexpr-2.6.2.ebuild58
3 files changed, 0 insertions, 118 deletions
diff --git a/dev-python/numexpr/Manifest b/dev-python/numexpr/Manifest
index eb78d48b25ad..904147a8678c 100644
--- a/dev-python/numexpr/Manifest
+++ b/dev-python/numexpr/Manifest
@@ -1,4 +1,2 @@
-DIST numexpr-2.6.1.tar.gz 90819 BLAKE2B 833402388e184bd38c449bcda866f68858f486d5cf30aec29dc5e9827a34a40cb166128a8fb217f0ed1614e0b759cf2164e31cb2a16198ea3e6a216c9fe01853 SHA512 07c88b1788ecad2c59260e7a6a15dfc21d486462a8866091d157286e5ce3b5b77f5fdab401fd30e2a5e4880398af53641d557003497c7d3658421bfcff38c31c
-DIST numexpr-2.6.2.tar.gz 90970 BLAKE2B 85034d7d36bd921df289f817451e7b30071b9d448dc050e4f25afd13315921e3c10d61a41983cf106606e4efd91504e94ca7d8f01d80b230a9f717f41eb687ee SHA512 730e19e61987ecb00bfc3a65db043c88a1311046f2ea5f0a48c93d6a8d7576dbaa166b0b9b0f547e344b21b5c269be1b5aa2097e88aaac55219884c7ece55261
DIST numexpr-2.6.8.tar.gz 94517 BLAKE2B b41593183d69cd98f81107da5abc3eb59b35c6e61c0dde213c9a201c2776e4684d8af4b1a88c59ca464a7755941de9baf2157af64e8662c4219ae8ece635aefb SHA512 e610a2e3891f12b3a9fd7acb14a0362e0f03084035aa274827ec5e7d2584f2c599493afaf406d8720d915c7ed834dca11b1fbf28c0645077eb63223a2bf52cf9
DIST numexpr-2.6.9.tar.gz 94419 BLAKE2B 22492c1c59306fbd93174b5bab2ffaa32628c52cc570871bd6192a4589b65b6f679a77c8ec6f37b0a2ac09f004364a2ba87ecc26f459cb2d4b3b2705196b9fdc SHA512 d43845fb63c1e7b645b282d251f7f112784dbc04b61af1ffcbb9646cbe2e3a9f5d38aaa000f7d49880abe44c25205a6ef1e284577d36868220a197cdc0e55166
diff --git a/dev-python/numexpr/numexpr-2.6.1.ebuild b/dev-python/numexpr/numexpr-2.6.1.ebuild
deleted file mode 100644
index 453de3de466f..000000000000
--- a/dev-python/numexpr/numexpr-2.6.1.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1 flag-o-matic
-
-DESCRIPTION="Fast numerical array expression evaluator for Python and NumPy"
-HOMEPAGE="https://github.com/pydata/numexpr"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
-IUSE="mkl"
-
-RDEPEND="
- >=dev-python/numpy-1.6[${PYTHON_USEDEP}]
- mkl? ( sci-libs/mkl )"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]"
-
-python_prepare_all() {
- # TODO: mkl can be used but it fails for me
- # only works with mkl in tree. newer mkl will use pkgconfig
- if use mkl; then
- use amd64 && local ext="_lp64"
- cat > site.cfg <<- _EOF_ || die
- [mkl]
- library_dirs = ${MKLROOT}/lib/em64t
- include_dirs = ${MKLROOT}/include
- mkl_libs = mkl_solver${ext}, mkl_intel${ext}, \
- mkl_intel_thread, mkl_core, iomp5
- _EOF_
- fi
-
- distutils-r1_python_prepare_all
-}
-
-python_compile() {
- if ! python_is_python3; then
- local -x CFLAGS="${CFLAGS}"
- append-cflags -fno-strict-aliasing
- fi
-
- distutils-r1_python_compile
-}
-
-python_test() {
- pushd "${BUILD_DIR}"/lib >/dev/null || die
- "${EPYTHON}" \
- -c "import sys;import numexpr;sys.exit(0 if numexpr.test() else 1)" \
- || die
- pushd >/dev/null || die
-}
diff --git a/dev-python/numexpr/numexpr-2.6.2.ebuild b/dev-python/numexpr/numexpr-2.6.2.ebuild
deleted file mode 100644
index 93836f5e9c2b..000000000000
--- a/dev-python/numexpr/numexpr-2.6.2.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1 flag-o-matic
-
-DESCRIPTION="Fast numerical array expression evaluator for Python and NumPy"
-HOMEPAGE="https://github.com/pydata/numexpr"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="mkl"
-
-RDEPEND="
- >=dev-python/numpy-1.6[${PYTHON_USEDEP}]
- mkl? ( sci-libs/mkl )"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]"
-
-python_prepare_all() {
- # TODO: mkl can be used but it fails for me
- # only works with mkl in tree. newer mkl will use pkgconfig
- if use mkl; then
- use amd64 && local ext="_lp64"
- cat > site.cfg <<- _EOF_ || die
- [mkl]
- library_dirs = ${MKLROOT}/lib/em64t
- include_dirs = ${MKLROOT}/include
- mkl_libs = mkl_solver${ext}, mkl_intel${ext}, \
- mkl_intel_thread, mkl_core, iomp5
- _EOF_
- fi
-
- distutils-r1_python_prepare_all
-}
-
-python_compile() {
- if ! python_is_python3; then
- local -x CFLAGS="${CFLAGS}"
- append-cflags -fno-strict-aliasing
- fi
-
- distutils-r1_python_compile
-}
-
-python_test() {
- pushd "${BUILD_DIR}"/lib >/dev/null || die
- "${EPYTHON}" \
- -c "import sys;import numexpr;sys.exit(0 if numexpr.test() else 1)" \
- || die
- pushd >/dev/null || die
-}