summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-08-22 09:07:52 +0200
committerMichał Górny <mgorny@gentoo.org>2020-08-22 09:07:52 +0200
commit63cdf2b57ced338c3f9aa86a931ca5b5a2c1564a (patch)
tree595b53ba533b8c14f93c78795fce6f4e7f7050b0 /dev-python/numexpr
parentdev-python/notebook: Remove redundant versions (diff)
downloadgentoo-63cdf2b57ced338c3f9aa86a931ca5b5a2c1564a.tar.gz
gentoo-63cdf2b57ced338c3f9aa86a931ca5b5a2c1564a.tar.bz2
gentoo-63cdf2b57ced338c3f9aa86a931ca5b5a2c1564a.zip
dev-python/numexpr: Remove redundant versions
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/numexpr')
-rw-r--r--dev-python/numexpr/Manifest1
-rw-r--r--dev-python/numexpr/numexpr-2.6.9.ebuild49
2 files changed, 0 insertions, 50 deletions
diff --git a/dev-python/numexpr/Manifest b/dev-python/numexpr/Manifest
index 5fdcd019a818..61bcc6c3ae55 100644
--- a/dev-python/numexpr/Manifest
+++ b/dev-python/numexpr/Manifest
@@ -1,2 +1 @@
-DIST numexpr-2.6.9.tar.gz 94419 BLAKE2B 22492c1c59306fbd93174b5bab2ffaa32628c52cc570871bd6192a4589b65b6f679a77c8ec6f37b0a2ac09f004364a2ba87ecc26f459cb2d4b3b2705196b9fdc SHA512 d43845fb63c1e7b645b282d251f7f112784dbc04b61af1ffcbb9646cbe2e3a9f5d38aaa000f7d49880abe44c25205a6ef1e284577d36868220a197cdc0e55166
DIST numexpr-2.7.1.tar.gz 99196 BLAKE2B 14912a0a50a46c085215f0a40467371859aedeaaf999f747d735df4c244529709b26c1257d3c5c05ed0ceea801d117bf6a330dbd30573fe274522e1101e2f4b3 SHA512 e8852ed1c7bd7f7e94ce5ad78de7a8a7ca30a5873dbfa4fae0a179fbcf956b1e66f2a09c1785f0d8d9e83a5cba359a55840a21784bc225aa01915a322709d370
diff --git a/dev-python/numexpr/numexpr-2.6.9.ebuild b/dev-python/numexpr/numexpr-2.6.9.ebuild
deleted file mode 100644
index a07deab3a74a..000000000000
--- a/dev-python/numexpr/numexpr-2.6.9.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_{6,7} )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1 flag-o-matic
-
-DESCRIPTION="Fast numerical array expression evaluator for Python and NumPy"
-HOMEPAGE="https://github.com/pydata/numexpr"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
-IUSE="mkl"
-
-RDEPEND="
- >=dev-python/numpy-1.6[${PYTHON_USEDEP}]
- mkl? ( sci-libs/mkl )"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]"
-
-python_prepare_all() {
- # TODO: mkl can be used but it fails for me
- # only works with mkl in tree. newer mkl will use pkgconfig
- if use mkl; then
- use amd64 && local ext="_lp64"
- cat > site.cfg <<- _EOF_ || die
- [mkl]
- library_dirs = ${MKLROOT}/lib/em64t
- include_dirs = ${MKLROOT}/include
- mkl_libs = mkl_solver${ext}, mkl_intel${ext}, \
- mkl_intel_thread, mkl_core, iomp5
- _EOF_
- fi
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- pushd "${BUILD_DIR}"/lib >/dev/null || die
- "${EPYTHON}" \
- -c "import sys,numexpr;sys.exit(0 if numexpr.test().wasSuccessful() else 1)" \
- || die
- pushd >/dev/null || die
-}