summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2020-06-06 22:51:58 +0200
committerPacho Ramos <pacho@gentoo.org>2020-06-06 23:07:26 +0200
commit799adfb1a6e14a4049096264bc2ee9334d8ff095 (patch)
tree13ad777f576fe14ab88d2e87d2b6651772947603 /dev-python/numexpr
parentdev-python/bottleneck: Bump to 1.3.2 (diff)
downloadgentoo-799adfb1a6e14a4049096264bc2ee9334d8ff095.tar.gz
gentoo-799adfb1a6e14a4049096264bc2ee9334d8ff095.tar.bz2
gentoo-799adfb1a6e14a4049096264bc2ee9334d8ff095.zip
dev-python/numexpr: Bump to 2.7.1
Closes: https://bugs.gentoo.org/723552 Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'dev-python/numexpr')
-rw-r--r--dev-python/numexpr/Manifest1
-rw-r--r--dev-python/numexpr/numexpr-2.7.1.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/dev-python/numexpr/Manifest b/dev-python/numexpr/Manifest
index 18504c4be5be..5fdcd019a818 100644
--- a/dev-python/numexpr/Manifest
+++ b/dev-python/numexpr/Manifest
@@ -1 +1,2 @@
DIST numexpr-2.6.9.tar.gz 94419 BLAKE2B 22492c1c59306fbd93174b5bab2ffaa32628c52cc570871bd6192a4589b65b6f679a77c8ec6f37b0a2ac09f004364a2ba87ecc26f459cb2d4b3b2705196b9fdc SHA512 d43845fb63c1e7b645b282d251f7f112784dbc04b61af1ffcbb9646cbe2e3a9f5d38aaa000f7d49880abe44c25205a6ef1e284577d36868220a197cdc0e55166
+DIST numexpr-2.7.1.tar.gz 99196 BLAKE2B 14912a0a50a46c085215f0a40467371859aedeaaf999f747d735df4c244529709b26c1257d3c5c05ed0ceea801d117bf6a330dbd30573fe274522e1101e2f4b3 SHA512 e8852ed1c7bd7f7e94ce5ad78de7a8a7ca30a5873dbfa4fae0a179fbcf956b1e66f2a09c1785f0d8d9e83a5cba359a55840a21784bc225aa01915a322709d370
diff --git a/dev-python/numexpr/numexpr-2.7.1.ebuild b/dev-python/numexpr/numexpr-2.7.1.ebuild
new file mode 100644
index 000000000000..138fd440b66e
--- /dev/null
+++ b/dev-python/numexpr/numexpr-2.7.1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{6..9} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1 flag-o-matic
+
+DESCRIPTION="Fast numerical array expression evaluator for Python and NumPy"
+HOMEPAGE="https://github.com/pydata/numexpr"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="mkl"
+
+RDEPEND="
+ >=dev-python/numpy-1.6[${PYTHON_USEDEP}]
+ mkl? ( sci-libs/mkl )
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+python_prepare_all() {
+ # TODO: mkl can be used but it fails for me
+ # only works with mkl in tree. newer mkl will use pkgconfig
+ if use mkl; then
+ use amd64 && local ext="_lp64"
+ cat > site.cfg <<- _EOF_ || die
+ [mkl]
+ library_dirs = ${MKLROOT}/lib/em64t
+ include_dirs = ${MKLROOT}/include
+ mkl_libs = mkl_solver${ext}, mkl_intel${ext}, \
+ mkl_intel_thread, mkl_core, iomp5
+ _EOF_
+ fi
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile() {
+ if ! python_is_python3; then
+ local -x CFLAGS="${CFLAGS}"
+ append-cflags -fno-strict-aliasing
+ fi
+
+ distutils-r1_python_compile
+}
+
+python_test() {
+ pushd "${BUILD_DIR}"/lib >/dev/null || die
+ "${EPYTHON}" \
+ -c "import sys,numexpr;sys.exit(0 if numexpr.test().wasSuccessful() else 1)" \
+ || die
+ pushd >/dev/null || die
+}