summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-12-02 15:16:36 +0100
committerMichał Górny <mgorny@gentoo.org>2021-12-02 15:16:53 +0100
commit9931c87ea1de7c0d43b6166b8352303b01130a19 (patch)
treeb0a5be643338cebc93f2afe9fe81aa3ebfdb6f73 /dev-python/numexpr
parentdev-python/numexpr: Attempt to fix building against mkl (diff)
downloadgentoo-9931c87ea1de7c0d43b6166b8352303b01130a19.tar.gz
gentoo-9931c87ea1de7c0d43b6166b8352303b01130a19.tar.bz2
gentoo-9931c87ea1de7c0d43b6166b8352303b01130a19.zip
dev-python/numexpr: Remove broken mkl support
Closes: https://bugs.gentoo.org/828015 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/numexpr')
-rw-r--r--dev-python/numexpr/numexpr-2.8.0.ebuild46
1 files changed, 1 insertions, 45 deletions
diff --git a/dev-python/numexpr/numexpr-2.8.0.ebuild b/dev-python/numexpr/numexpr-2.8.0.ebuild
index 2de92876f671..a456aa137930 100644
--- a/dev-python/numexpr/numexpr-2.8.0.ebuild
+++ b/dev-python/numexpr/numexpr-2.8.0.ebuild
@@ -6,7 +6,7 @@ EAPI=8
PYTHON_COMPAT=( python3_{8..10} )
PYTHON_REQ_USE="threads(+)"
-inherit distutils-r1 toolchain-funcs
+inherit distutils-r1
DESCRIPTION="Fast numerical array expression evaluator for Python and NumPy"
HOMEPAGE="https://github.com/pydata/numexpr"
@@ -15,55 +15,11 @@ SRC_URI="https://github.com/pydata/numexpr/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
-IUSE="mkl"
DEPEND="
>=dev-python/numpy-1.6[${PYTHON_USEDEP}]
- mkl? ( sci-libs/mkl )
"
RDEPEND=${DEPEND}
-BDEPEND="
- mkl? ( virtual/pkgconfig )
-"
-
-python_prepare_all() {
- # TODO: mkl can be used but it fails for me
- # only works with mkl in tree. newer mkl will use pkgconfig
- if use mkl; then
- local suffix=
- use amd64 && local suffix="-lp64"
-
- local flags=(
- $($(tc-getPKG_CONFIG) --cflags --libs "mkl-dynamic${suffix}-iomp")
- )
- local f libdirs=() incdirs=() libs=()
- for f in "${flags[@]}"; do
- case ${f} in
- -I*)
- incdirs+=( "${f#-I}" )
- ;;
- -L*)
- libdirs+=( "${f#-L}" )
- ;;
- -l*)
- libs+=( "${f#-l}" )
- ;;
- *)
- die "Unexpected flag in pkg-config output: ${f}"
- ;;
- esac
- done
-
- cat > site.cfg <<- _EOF_ || die
- [mkl]
- library_dirs = $(IFS=:; echo "${libdirs[*]}")
- include_dirs = $(IFS=:; echo "${incdirs[*]}")
- libraries = $(IFS=:; echo "${libs[*]}")
- _EOF_
- fi
-
- distutils-r1_python_prepare_all
-}
python_test() {
pushd "${BUILD_DIR}"/lib >/dev/null || die