summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-10-09 10:41:56 +0200
committerMichał Górny <mgorny@gentoo.org>2020-10-09 10:46:05 +0200
commitb0c0d77fc8c786cf0c92e26a344634169365f797 (patch)
tree28a96be71daa99f880df8401af5825cec374019c /dev-python/numexpr
parentdev-python/cbor2: Remove old (diff)
downloadgentoo-b0c0d77fc8c786cf0c92e26a344634169365f797.tar.gz
gentoo-b0c0d77fc8c786cf0c92e26a344634169365f797.tar.bz2
gentoo-b0c0d77fc8c786cf0c92e26a344634169365f797.zip
dev-python/numexpr: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/numexpr')
-rw-r--r--dev-python/numexpr/Manifest1
-rw-r--r--dev-python/numexpr/numexpr-2.7.1.ebuild51
2 files changed, 0 insertions, 52 deletions
diff --git a/dev-python/numexpr/Manifest b/dev-python/numexpr/Manifest
index 278b612c5d9c..bb55c8487ed5 100644
--- a/dev-python/numexpr/Manifest
+++ b/dev-python/numexpr/Manifest
@@ -1,2 +1 @@
-DIST numexpr-2.7.1.tar.gz 99196 BLAKE2B 14912a0a50a46c085215f0a40467371859aedeaaf999f747d735df4c244529709b26c1257d3c5c05ed0ceea801d117bf6a330dbd30573fe274522e1101e2f4b3 SHA512 e8852ed1c7bd7f7e94ce5ad78de7a8a7ca30a5873dbfa4fae0a179fbcf956b1e66f2a09c1785f0d8d9e83a5cba359a55840a21784bc225aa01915a322709d370
DIST numexpr-2.7.2.gh.tar.gz 118982 BLAKE2B b032f00c36ffadb88cf9a4cd6323137b920bce48ec73f88f006d3186f9a8c1d75a11ceb6bd32f412cba5c10cbe3cb518cdbdb19ef022100fcc408fc82ede9881 SHA512 41946df6d642e226b4a38b11d5db67ef91d63d56b33d3b52f09377c022d236ea4e9a5aaaf380737d18405ee25109260ae60f79d0c9465b95de14465f41c40075
diff --git a/dev-python/numexpr/numexpr-2.7.1.ebuild b/dev-python/numexpr/numexpr-2.7.1.ebuild
deleted file mode 100644
index eed440f7e010..000000000000
--- a/dev-python/numexpr/numexpr-2.7.1.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_{6..9} )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1 flag-o-matic
-
-DESCRIPTION="Fast numerical array expression evaluator for Python and NumPy"
-HOMEPAGE="https://github.com/pydata/numexpr"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 x86 ~amd64-linux ~x86-linux"
-IUSE="mkl"
-
-RDEPEND="
- >=dev-python/numpy-1.6[${PYTHON_USEDEP}]
- mkl? ( sci-libs/mkl )
-"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
-"
-
-python_prepare_all() {
- # TODO: mkl can be used but it fails for me
- # only works with mkl in tree. newer mkl will use pkgconfig
- if use mkl; then
- use amd64 && local ext="_lp64"
- cat > site.cfg <<- _EOF_ || die
- [mkl]
- library_dirs = ${MKLROOT}/lib/em64t
- include_dirs = ${MKLROOT}/include
- mkl_libs = mkl_solver${ext}, mkl_intel${ext}, \
- mkl_intel_thread, mkl_core, iomp5
- _EOF_
- fi
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- pushd "${BUILD_DIR}"/lib >/dev/null || die
- "${EPYTHON}" \
- -c "import sys,numexpr;sys.exit(0 if numexpr.test().wasSuccessful() else 1)" \
- || die
- pushd >/dev/null || die
-}