summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2016-02-13 10:26:32 -0600
committerKacper Kowalik <xarthisius@gentoo.org>2016-02-13 10:26:32 -0600
commit926294cba807531ad8aa9f15e8bf18bf521f22b5 (patch)
tree51691bbd5a5209c66f1d23a988d471d599b40e7c /dev-python/numpydoc/numpydoc-0.6.0.ebuild
parentsys-apps/haveged: remove old initd file (diff)
downloadgentoo-926294cba807531ad8aa9f15e8bf18bf521f22b5.tar.gz
gentoo-926294cba807531ad8aa9f15e8bf18bf521f22b5.tar.bz2
gentoo-926294cba807531ad8aa9f15e8bf18bf521f22b5.zip
dev-python/numpydoc: version bump to 0.6.0
Package-Manager: portage-2.2.27
Diffstat (limited to 'dev-python/numpydoc/numpydoc-0.6.0.ebuild')
-rw-r--r--dev-python/numpydoc/numpydoc-0.6.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/numpydoc/numpydoc-0.6.0.ebuild b/dev-python/numpydoc/numpydoc-0.6.0.ebuild
new file mode 100644
index 000000000000..9577ca491677
--- /dev/null
+++ b/dev-python/numpydoc/numpydoc-0.6.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Sphinx extension to support docstrings in Numpy format"
+HOMEPAGE="https://pypi.python.org/pypi/numpydoc"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~x86 ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="test"
+
+RDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ >=dev-python/matplotlib-1.4.0[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ esetup.py test
+}