summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-10-10 15:50:26 +0200
committerMichał Górny <mgorny@gentoo.org>2022-10-10 16:04:32 +0200
commit6e6b134e0746b698732b2c0440ed286b814db922 (patch)
tree9bfccf2c3a4c4e055b56e61576d72f71d843df7b /dev-python/numpydoc/numpydoc-1.5.0.ebuild
parentdev-python/zipp: Bump to 3.9.0 (diff)
downloadgentoo-6e6b134e0746b698732b2c0440ed286b814db922.tar.gz
gentoo-6e6b134e0746b698732b2c0440ed286b814db922.tar.bz2
gentoo-6e6b134e0746b698732b2c0440ed286b814db922.zip
dev-python/numpydoc: Bump to 1.5.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/numpydoc/numpydoc-1.5.0.ebuild')
-rw-r--r--dev-python/numpydoc/numpydoc-1.5.0.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/numpydoc/numpydoc-1.5.0.ebuild b/dev-python/numpydoc/numpydoc-1.5.0.ebuild
new file mode 100644
index 000000000000..e031076473c2
--- /dev/null
+++ b/dev-python/numpydoc/numpydoc-1.5.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Sphinx extension to support docstrings in Numpy format"
+HOMEPAGE="
+ https://numpydoc.readthedocs.io/en/latest/
+ https://github.com/numpy/numpydoc/
+ https://pypi.org/project/numpydoc/
+"
+SRC_URI="
+ https://github.com/numpy/numpydoc/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ >=dev-python/jinja-2.10[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-4.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/matplotlib-3.2.1[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e 's:--cov-report= --cov=numpydoc::' setup.cfg || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # these require Internet (intersphinx)
+ numpydoc/tests/test_full.py::test_MyClass
+ numpydoc/tests/test_full.py::test_my_function
+ )
+ epytest --pyargs numpydoc
+}