summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-28 17:13:23 +0200
committerMichał Górny <mgorny@gentoo.org>2023-10-28 17:23:46 +0200
commit8b22e476be3608b1831daf8847785ac68c83bd55 (patch)
tree9a81ae3d2ceeac1ee4f27fd3ae276c78e56dcf14 /dev-python/numpydoc/numpydoc-1.5.0.ebuild
parentdev-python/numpydoc: Keyword 1.6.0 ia64, #914730 (diff)
downloadgentoo-8b22e476be3608b1831daf8847785ac68c83bd55.tar.gz
gentoo-8b22e476be3608b1831daf8847785ac68c83bd55.tar.bz2
gentoo-8b22e476be3608b1831daf8847785ac68c83bd55.zip
dev-python/numpydoc: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/numpydoc/numpydoc-1.5.0.ebuild')
-rw-r--r--dev-python/numpydoc/numpydoc-1.5.0.ebuild51
1 files changed, 0 insertions, 51 deletions
diff --git a/dev-python/numpydoc/numpydoc-1.5.0.ebuild b/dev-python/numpydoc/numpydoc-1.5.0.ebuild
deleted file mode 100644
index 53d87a1b4ea5..000000000000
--- a/dev-python/numpydoc/numpydoc-1.5.0.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="Sphinx extension to support docstrings in Numpy format"
-HOMEPAGE="
- https://numpydoc.readthedocs.io/en/latest/
- https://github.com/numpy/numpydoc/
- https://pypi.org/project/numpydoc/
-"
-SRC_URI="
- https://github.com/numpy/numpydoc/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos"
-
-RDEPEND="
- >=dev-python/jinja-2.10[${PYTHON_USEDEP}]
- >=dev-python/sphinx-4.2[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- >=dev-python/matplotlib-3.2.1[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- sed -i -e 's:--cov-report= --cov=numpydoc::' setup.cfg || die
-
- distutils-r1_src_prepare
-}
-
-python_test() {
- local EPYTEST_DESELECT=(
- # these require Internet (intersphinx)
- numpydoc/tests/test_full.py::test_MyClass
- numpydoc/tests/test_full.py::test_my_function
- )
- epytest --pyargs numpydoc
-}