summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-10-14 14:44:47 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2021-10-14 15:12:28 +0300
commitfec3a1ebbe1b74519bbb910e6d436f079694602f (patch)
tree9ed89cdfaf68d35e45bb57e8015ffdf1c2616194 /dev-python/numpydoc
parentdev-python/numpydoc: add github upstream metadata (diff)
downloadgentoo-fec3a1ebbe1b74519bbb910e6d436f079694602f.tar.gz
gentoo-fec3a1ebbe1b74519bbb910e6d436f079694602f.tar.bz2
gentoo-fec3a1ebbe1b74519bbb910e6d436f079694602f.zip
dev-python/numpydoc: enable py3.10, cleaner test deselect
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/numpydoc')
-rw-r--r--dev-python/numpydoc/numpydoc-1.1.0.ebuild14
1 files changed, 7 insertions, 7 deletions
diff --git a/dev-python/numpydoc/numpydoc-1.1.0.ebuild b/dev-python/numpydoc/numpydoc-1.1.0.ebuild
index ff3887528405..5693d12146fa 100644
--- a/dev-python/numpydoc/numpydoc-1.1.0.ebuild
+++ b/dev-python/numpydoc/numpydoc-1.1.0.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
@@ -30,14 +30,14 @@ distutils_enable_tests pytest
src_prepare() {
sed -i -e 's:--cov-report= --cov=numpydoc::' setup.cfg || die
- # these require Internet (intersphinx)
- sed -e 's:test_MyClass:_&:' \
- -e 's:test_my_function:_&:' \
- -i numpydoc/tests/test_full.py || die
-
distutils-r1_src_prepare
}
python_test() {
- pytest -vv --pyargs numpydoc || die "Tests failed with ${EPYTHON}"
+ local EPYTEST_DESELECT=(
+ # these require Internet (intersphinx)
+ numpydoc/tests/test_full.py::test_MyClass
+ numpydoc/tests/test_full.py::test_my_function
+ )
+ epytest --pyargs numpydoc
}