summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sautier.louis@gmail.com>2017-01-18 10:58:22 +0100
committerDavid Seifert <soap@gentoo.org>2017-01-18 11:27:15 +0100
commit0d41d50c911131409bb7442a30425acfdaebd761 (patch)
tree772b914534d783a5c7919adfe54f2cbd3da1d8c8 /dev-python/oauth2/oauth2-1.9.0_p1-r1.ebuild
parentdev-python/oauth2: convert patch to -p1 (diff)
downloadgentoo-0d41d50c911131409bb7442a30425acfdaebd761.tar.gz
gentoo-0d41d50c911131409bb7442a30425acfdaebd761.tar.bz2
gentoo-0d41d50c911131409bb7442a30425acfdaebd761.zip
dev-python/oauth2: add py3.5, fix tests
Package-Manager: Portage-2.3.3, Repoman-2.3.1 Closes: https://github.com/gentoo/gentoo/pull/3522
Diffstat (limited to 'dev-python/oauth2/oauth2-1.9.0_p1-r1.ebuild')
-rw-r--r--dev-python/oauth2/oauth2-1.9.0_p1-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/oauth2/oauth2-1.9.0_p1-r1.ebuild b/dev-python/oauth2/oauth2-1.9.0_p1-r1.ebuild
new file mode 100644
index 000000000000..ba3b98f2f1d3
--- /dev/null
+++ b/dev-python/oauth2/oauth2-1.9.0_p1-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} pypy )
+
+inherit distutils-r1
+
+MY_P="${P/_p/.post}"
+
+DESCRIPTION="Library for OAuth version 1.0"
+HOMEPAGE="https://pypi.python.org/pypi/oauth2"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x64-macos"
+IUSE="test"
+
+RDEPEND="dev-python/httplib2[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND}
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )"
+
+# https://github.com/joestump/python-oauth2/pull/212
+PATCHES=( "${FILESDIR}/${PV}-exclude-tests.patch" )
+S="${WORKDIR}/${MY_P}"
+
+python_test() {
+ # Skip tests which require network access
+ py.test -k "not (test_access_token_post or test_access_token_get \
+ or test_two_legged_post or test_two_legged_get)" || die \
+ "tests failed with ${EPYTHON}"
+}