summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-03-04 03:50:49 +0000
committerSam James <sam@gentoo.org>2021-03-04 03:50:49 +0000
commitfc0e1b6523126ff3f181e5fedeae94f8a2348403 (patch)
treecf8d7e57240bfe2287240edc37f06ba1c5cbe344 /dev-python/oauth2
parentdev-python/audioread: add github remote-id (diff)
downloadgentoo-fc0e1b6523126ff3f181e5fedeae94f8a2348403.tar.gz
gentoo-fc0e1b6523126ff3f181e5fedeae94f8a2348403.tar.bz2
gentoo-fc0e1b6523126ff3f181e5fedeae94f8a2348403.zip
dev-python/oauth2: add Python 3.9
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/oauth2')
-rw-r--r--dev-python/oauth2/oauth2-1.9.0_p1-r1.ebuild18
1 files changed, 9 insertions, 9 deletions
diff --git a/dev-python/oauth2/oauth2-1.9.0_p1-r1.ebuild b/dev-python/oauth2/oauth2-1.9.0_p1-r1.ebuild
index 37eb7d636802..4153a69ecea5 100644
--- a/dev-python/oauth2/oauth2-1.9.0_p1-r1.ebuild
+++ b/dev-python/oauth2/oauth2-1.9.0_p1-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-PYTHON_COMPAT=( python3_{7,8} )
+PYTHON_COMPAT=( python3_{7,8,9} )
inherit distutils-r1
@@ -12,24 +12,24 @@ MY_P="${P/_p/.post}"
DESCRIPTION="Library for OAuth version 1.0"
HOMEPAGE="https://pypi.org/project/oauth2/"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
LICENSE="MIT"
SLOT="0"
KEYWORDS="amd64 x86 ~x64-macos"
-IUSE="test"
-RESTRICT="!test? ( test )"
RDEPEND="dev-python/httplib2[${PYTHON_USEDEP}]"
DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
test? ( ${RDEPEND}
dev-python/mock[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
)"
# https://github.com/joestump/python-oauth2/pull/212
-PATCHES=( "${FILESDIR}/${PV}-exclude-tests.patch" )
-S="${WORKDIR}/${MY_P}"
+PATCHES=(
+ "${FILESDIR}/${PV}-exclude-tests.patch"
+)
+
+distutils_enable_tests pytest
python_test() {
# Skip tests which require network access