summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-07-12 18:43:28 +0200
committerMichał Górny <mgorny@gentoo.org>2020-07-12 18:53:41 +0200
commit75e38c55e4ca9f8bcc12344bf9ffa35f40673a9a (patch)
tree9f871538725cd0209981803d90abf9d30ec3433e /dev-python/oauth2client/oauth2client-4.1.3.ebuild
parentdev-python/numpydoc: Remove redundant versions (diff)
downloadgentoo-75e38c55e4ca9f8bcc12344bf9ffa35f40673a9a.tar.gz
gentoo-75e38c55e4ca9f8bcc12344bf9ffa35f40673a9a.tar.bz2
gentoo-75e38c55e4ca9f8bcc12344bf9ffa35f40673a9a.zip
dev-python/oauth2client: Remove redundant versions
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/oauth2client/oauth2client-4.1.3.ebuild')
-rw-r--r--dev-python/oauth2client/oauth2client-4.1.3.ebuild52
1 files changed, 0 insertions, 52 deletions
diff --git a/dev-python/oauth2client/oauth2client-4.1.3.ebuild b/dev-python/oauth2client/oauth2client-4.1.3.ebuild
deleted file mode 100644
index 5901030b4f92..000000000000
--- a/dev-python/oauth2client/oauth2client-4.1.3.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python3_{6,7} )
-
-inherit distutils-r1
-
-DESCRIPTION="Library for accessing resources protected by OAuth 2.0"
-HOMEPAGE="https://github.com/googleapis/oauth2client"
-SRC_URI="https://github.com/googleapis/oauth2client/archive/v${PV/_p/-post}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-RESTRICT="!test? ( test )"
-REQUIRED_USE="|| ( $(python_gen_useflags 'python*') )"
-
-RDEPEND="
- >=dev-python/httplib2-0.9.1[${PYTHON_USEDEP}]
- >=dev-python/pyasn1-0.1.7[${PYTHON_USEDEP}]
- >=dev-python/pyasn1-modules-0.0.5[${PYTHON_USEDEP}]
- >=dev-python/rsa-3.1.4[${PYTHON_USEDEP}]
- >=dev-python/six-1.6.1[${PYTHON_USEDEP}]
- dev-python/keyring[${PYTHON_USEDEP}]
- !<=dev-python/google-api-python-client-1.1[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/nose[${PYTHON_USEDEP}] )
-"
-
-S="${WORKDIR}"/${P/_p/-post}
-
-python_prepare() {
- # keyring is not fuly supported by pypy yet, because dbus-python can't support pypy
- # oauth2client -> keyring -> secretstorage -> dbus-python
- # https://github.com/mitya57/secretstorage/issues/10
- case $PYTHON in
- pypy|*pypy|*pypy3|pypy3) \
- find "${BUILD_DIR}/.." -name '*keyring*py' -delete ;;
- esac
-}
-
-python_test() {
- nosetests -e appengine -e django_util -e test_multiprocess_file_storage -e test_bad_positional || die
- # appengine - requires appengine
- # django_util - requires django
- # test_multiprocess_file_storage - requires fasteners
- # test_bad_positional - expects TypeError, gets ValueError
-}