summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-12-10 23:02:54 +0100
committerMichał Górny <mgorny@gentoo.org>2019-12-11 00:22:38 +0100
commit064af661d0c9a31cecdf348632bc5603333a9149 (patch)
tree2202373a7cafcb8a761d32747d4f62263aed64d5 /dev-python/oauthlib
parentdev-python/passlib: keyworded 1.7.1-r2 for hppa, bug #700918 (diff)
downloadgentoo-064af661d0c9a31cecdf348632bc5603333a9149.tar.gz
gentoo-064af661d0c9a31cecdf348632bc5603333a9149.tar.bz2
gentoo-064af661d0c9a31cecdf348632bc5603333a9149.zip
*/*: [QA] Fix trivial cases of MissingTestRestrict
The result was achieved via the following pipeline: pkgcheck scan -c RestrictTestCheck -R FormatReporter \ --format '{category}/{package}/{package}-{version}.ebuild' | xargs -n32 grep -L RESTRICT | xargs -n32 sed -i -e '/^IUSE=.*test/aRESTRICT="!test? ( test )"' The resulting metadata was compared before and after the change. Few Go ebuilds had to be fixed manually due to implicit RESTRICT=strip added by the eclass. Two ebuilds have to be fixed because of multiline IUSE. Suggested-by: Robin H. Johnson <robbat2@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/13942 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/oauthlib')
-rw-r--r--dev-python/oauthlib/oauthlib-1.0.3.ebuild1
-rw-r--r--dev-python/oauthlib/oauthlib-2.0.2.ebuild1
-rw-r--r--dev-python/oauthlib/oauthlib-2.0.3.ebuild1
-rw-r--r--dev-python/oauthlib/oauthlib-2.0.6.ebuild1
-rw-r--r--dev-python/oauthlib/oauthlib-3.0.1.ebuild1
5 files changed, 5 insertions, 0 deletions
diff --git a/dev-python/oauthlib/oauthlib-1.0.3.ebuild b/dev-python/oauthlib/oauthlib-1.0.3.ebuild
index 29e15d6afae1..0acdb63954bb 100644
--- a/dev-python/oauthlib/oauthlib-1.0.3.ebuild
+++ b/dev-python/oauthlib/oauthlib-1.0.3.ebuild
@@ -15,6 +15,7 @@ LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~x86"
IUSE="test"
+RESTRICT="!test? ( test )"
# optional extras hard set as RDEPs. See setup.py
RDEPEND="
diff --git a/dev-python/oauthlib/oauthlib-2.0.2.ebuild b/dev-python/oauthlib/oauthlib-2.0.2.ebuild
index 619002d64ece..919b14561e47 100644
--- a/dev-python/oauthlib/oauthlib-2.0.2.ebuild
+++ b/dev-python/oauthlib/oauthlib-2.0.2.ebuild
@@ -15,6 +15,7 @@ LICENSE="BSD"
SLOT="0"
KEYWORDS="amd64 ~arm ~arm64 x86"
IUSE="test"
+RESTRICT="!test? ( test )"
# optional extras hard set as RDEPs. See setup.py
RDEPEND="
diff --git a/dev-python/oauthlib/oauthlib-2.0.3.ebuild b/dev-python/oauthlib/oauthlib-2.0.3.ebuild
index ef91952bf239..32f70904eb54 100644
--- a/dev-python/oauthlib/oauthlib-2.0.3.ebuild
+++ b/dev-python/oauthlib/oauthlib-2.0.3.ebuild
@@ -15,6 +15,7 @@ LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~x86"
IUSE="test"
+RESTRICT="!test? ( test )"
# optional extras hard set as RDEPs. See setup.py
RDEPEND="
diff --git a/dev-python/oauthlib/oauthlib-2.0.6.ebuild b/dev-python/oauthlib/oauthlib-2.0.6.ebuild
index 30f6eab4fca5..0af9e26f7932 100644
--- a/dev-python/oauthlib/oauthlib-2.0.6.ebuild
+++ b/dev-python/oauthlib/oauthlib-2.0.6.ebuild
@@ -15,6 +15,7 @@ LICENSE="BSD"
SLOT="0"
KEYWORDS="amd64 ~arm ~arm64 x86"
IUSE="test"
+RESTRICT="!test? ( test )"
# optional extras hard set as RDEPs. See setup.py
RDEPEND="
diff --git a/dev-python/oauthlib/oauthlib-3.0.1.ebuild b/dev-python/oauthlib/oauthlib-3.0.1.ebuild
index 932e50a80b7a..ea5f90da996b 100644
--- a/dev-python/oauthlib/oauthlib-3.0.1.ebuild
+++ b/dev-python/oauthlib/oauthlib-3.0.1.ebuild
@@ -15,6 +15,7 @@ LICENSE="BSD"
SLOT="0"
KEYWORDS="amd64 ~arm ~arm64 x86"
IUSE="test"
+RESTRICT="!test? ( test )"
# optional extras hard set as RDEPs. See setup.py
RDEPEND="