summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2019-03-26 15:12:54 -0700
committerPatrick McLean <chutzpah@gentoo.org>2019-03-26 18:07:08 -0700
commit747ae321d9f4e638cb29bf4ec6268cb7b3211bfe (patch)
tree9f156f7762b47f4e5ce0dd795e9fddcba58095c9 /dev-python/objgraph/objgraph-3.4.0.ebuild
parentdev-python/pure-sasl: New package (diff)
downloadgentoo-747ae321d9f4e638cb29bf4ec6268cb7b3211bfe.tar.gz
gentoo-747ae321d9f4e638cb29bf4ec6268cb7b3211bfe.tar.bz2
gentoo-747ae321d9f4e638cb29bf4ec6268cb7b3211bfe.zip
dev-python/objgraph: Version bump to 3.4.0
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-python/objgraph/objgraph-3.4.0.ebuild')
-rw-r--r--dev-python/objgraph/objgraph-3.4.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/objgraph/objgraph-3.4.0.ebuild b/dev-python/objgraph/objgraph-3.4.0.ebuild
new file mode 100644
index 000000000000..9a701f9fbbdf
--- /dev/null
+++ b/dev-python/objgraph/objgraph-3.4.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Draws Python object reference graphs with graphviz"
+HOMEPAGE="https://mg.pov.lt/objgraph/"
+SRC_URI="mirror://pypi/o/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+SLOT="0"
+IUSE="doc test"
+
+RDEPEND="media-gfx/graphviz"
+DEPEND="dev-python/setuptools
+ test? ( media-gfx/xdot )"
+
+python_test() {
+ esetup.py test || die
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/* )
+ distutils-r1_python_install_all
+}