summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-08-22 19:29:24 +0200
committerDavid Seifert <soap@gentoo.org>2020-08-22 19:29:24 +0200
commitb4e4747cc3a763429187f46f2d12f2dc82f50169 (patch)
treec4f029cfeb480ff6111a5adc72b3cdb828c1b40e /dev-python/oct2py
parentdev-python/octave_kernel: Remove old 0.26.2 (diff)
downloadgentoo-b4e4747cc3a763429187f46f2d12f2dc82f50169.tar.gz
gentoo-b4e4747cc3a763429187f46f2d12f2dc82f50169.tar.bz2
gentoo-b4e4747cc3a763429187f46f2d12f2dc82f50169.zip
dev-python/oct2py: Version bump to 5.2.0
Bug: https://bugs.gentoo.org/726346 Bug: https://bugs.gentoo.org/731458 Bug: https://bugs.gentoo.org/732946 Bug: https://bugs.gentoo.org/737368 Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-python/oct2py')
-rw-r--r--dev-python/oct2py/Manifest1
-rw-r--r--dev-python/oct2py/files/oct2py-5.2.0-mask-pkg-load-test.patch10
-rw-r--r--dev-python/oct2py/oct2py-5.2.0.ebuild53
3 files changed, 64 insertions, 0 deletions
diff --git a/dev-python/oct2py/Manifest b/dev-python/oct2py/Manifest
index fb71e0fb952a..b7f9d1b5ee4f 100644
--- a/dev-python/oct2py/Manifest
+++ b/dev-python/oct2py/Manifest
@@ -1,2 +1,3 @@
DIST oct2py-3.6.0.tar.gz 668836 BLAKE2B 2edafd7c054a70a604273a7f3f5846926cb54dd05e7f2625aad57034d7760c099e9ad01120b719d3d047e6e6aa11f16e5fe8ca58e51079f038cea6d7aa3efe13 SHA512 f414a0231665bc3bedb7dcdaab8c86f32c140e5107ef80b70e2f99467e737d033de6ff492f2af7233671bff9b148475e0af4881c073ac727d0fd1228b7cf59b6
DIST oct2py-4.0.6.tar.gz 431738 BLAKE2B d76fd323fa2405cd70dd1d4cbbdf64bbd346d45dc8065de0913d44d833f6d609d20ec8887cefeafdc4e59c382f862a8954b395557ff5ec127a67b1df2d560083 SHA512 997ca843571d2d68c4c57c0213a525c1be5f8b3e3dbffffb6cd41e423d68c8836dd12a03d5210d7f0cbf8ff19be7bb9d25b48c62a236cae68a0762547e574caa
+DIST oct2py-5.2.0.tar.gz 436128 BLAKE2B 674bd034a44aa9cdb5fd4258c96665fda1b1d79a13ae9fa8d36d168e39385a978ed75bf8748ecdd53f57720785ea8e6c5ffd85d81f3b3c307a748fbc8d328a86 SHA512 55c2ee68b4fd73a8901fa2f7f67fefde5fa37d5070434aee03bfa2a746ff5179f51ccb96541a112e416438eb912caa81e040a5a1cbcbfac36b0285d496ac96fd
diff --git a/dev-python/oct2py/files/oct2py-5.2.0-mask-pkg-load-test.patch b/dev-python/oct2py/files/oct2py-5.2.0-mask-pkg-load-test.patch
new file mode 100644
index 000000000000..c233b45ec2c7
--- /dev/null
+++ b/dev-python/oct2py/files/oct2py-5.2.0-mask-pkg-load-test.patch
@@ -0,0 +1,10 @@
+--- a/oct2py/tests/test_usage.py
++++ b/oct2py/tests/test_usage.py
+@@ -338,6 +338,7 @@
+ with pytest.raises(Oct2PyError, match=exp):
+ self.oc.pyeval_like_error3(1)
+
++ @pytest.mark.skip(reason="requires octave 'signal' package to be installed")
+ def test_pkg_load(self):
+ self.oc.eval('pkg load signal')
+ t = np.linspace(0, 1, num=100)
diff --git a/dev-python/oct2py/oct2py-5.2.0.ebuild b/dev-python/oct2py/oct2py-5.2.0.ebuild
new file mode 100644
index 000000000000..ddc73b701cdc
--- /dev/null
+++ b/dev-python/oct2py/oct2py-5.2.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python to GNU Octave bridge"
+HOMEPAGE="
+ https://github.com/blink1073/oct2py
+ https://blink1073.github.io/oct2py/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples"
+
+RDEPEND="
+ >=dev-python/numpy-1.12[${PYTHON_USEDEP}]
+ >=dev-python/octave_kernel-0.31.0[${PYTHON_USEDEP}]
+ >=sci-libs/scipy-0.17[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ dev-python/ipython[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_sphinx docs \
+ dev-python/numpydoc dev-python/sphinx-bootstrap-theme dev-python/sphinx_rtd_theme
+distutils_enable_tests pytest
+
+PATCHES=( "${FILESDIR}"/${PN}-5.2.0-mask-pkg-load-test.patch )
+
+python_test() {
+ cd "${BUILD_DIR}"/lib || die
+ pytest -vv || die "Tests fail with ${EPYTHON}"
+
+ # remove cache which breaks python_install()
+ rm -r .pytest_cache || die
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ if use examples; then
+ docinto examples
+ dodoc -r example/.
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}