summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2016-11-23 08:45:35 +0100
committerDavid Seifert <soap@gentoo.org>2016-11-23 08:46:10 +0100
commitd27b5cd9c1c4ef67f73463206bd0e009ed5039db (patch)
tree7e64823d908d08ff330c8ffbf13cc152658e3c86 /dev-python/oct2py
parentmedia-sound/moc: version bumps to 2.5.2 and 2.6_alpha3 (diff)
downloadgentoo-d27b5cd9c1c4ef67f73463206bd0e009ed5039db.tar.gz
gentoo-d27b5cd9c1c4ef67f73463206bd0e009ed5039db.tar.bz2
gentoo-d27b5cd9c1c4ef67f73463206bd0e009ed5039db.zip
dev-python/oct2py: Version bump to 3.6.0
Package-Manager: portage-2.3.2
Diffstat (limited to 'dev-python/oct2py')
-rw-r--r--dev-python/oct2py/Manifest1
-rw-r--r--dev-python/oct2py/oct2py-3.6.0.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/dev-python/oct2py/Manifest b/dev-python/oct2py/Manifest
index f405dc27ff1f..b1f9f0f6dccc 100644
--- a/dev-python/oct2py/Manifest
+++ b/dev-python/oct2py/Manifest
@@ -1,2 +1,3 @@
DIST oct2py-1.3.0.tar.gz 321768 SHA256 f0cae7aae111631c0fffb7f2511ee14fb847b4f501340e8506b0805b50c32f28 SHA512 b9a8896fa463356a08dee7cd2db97bedd5487d93ed33fe73e2c5205118915eac86dcd51dea42dc7338a7f6486704d1c8cb3259c3d8a2b53230c50608d1d043d8 WHIRLPOOL f06214e8005281fec801856596f076a5ad0c35bc3bdc62db3057b320ac1ef8ab07a7f073c4e9ced62ce336c64e773128d333fd0bb26fb891ea6931b84ee22001
DIST oct2py-3.3.3.tar.gz 666775 SHA256 0b881a25043d7be713dab5d38b0f96acef5a4cf8130e5726cb9a6bec78448180 SHA512 02c80be8480c5b846a4269155c54fbea1ce8642c8bba0ecb6074a2468b20b930f8ba6d5eaae6a8274a02c1c6719e5b96ee5a32c0c4c0697c028c98ffa327c8e5 WHIRLPOOL 6eb6802b07b55a2ad0d56a8728262e1bc5720a0d9fab04e5af3e961e6a68821e9c2b52905507439ba388d6761aea047d45526fb39d1e50ca3b2104b20c20eb27
+DIST oct2py-3.6.0.tar.gz 668836 SHA256 b356daf63a80c778fcf81b380c187863b86e9aae88f8321bb543c5512835c69f SHA512 f414a0231665bc3bedb7dcdaab8c86f32c140e5107ef80b70e2f99467e737d033de6ff492f2af7233671bff9b148475e0af4881c073ac727d0fd1228b7cf59b6 WHIRLPOOL 498b69f6292fe60b1035ea8ef587b3dc7b49fb4353bf31ce5f19ca3afc74a3b4bdcff7700d77d6bd8e6bf079c590114fee1c2f0352127745d162fc3f6be9b3b9
diff --git a/dev-python/oct2py/oct2py-3.6.0.ebuild b/dev-python/oct2py/oct2py-3.6.0.ebuild
new file mode 100644
index 000000000000..b8a4d0dc6a51
--- /dev/null
+++ b/dev-python/oct2py/oct2py-3.6.0.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python to GNU Octave bridge"
+HOMEPAGE="
+ https://pypi.python.org/pypi/oct2py
+ http://pythonhosted.org/oct2py/
+ https://github.com/blink1073/oct2py"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples test"
+
+RDEPEND="
+ >=dev-python/numpy-1.7.1[${PYTHON_USEDEP}]
+ >=sci-libs/scipy-0.12[${PYTHON_USEDEP}]
+ >=sci-mathematics/octave-4.2.0"
+DEPEND="${RDEPEND}
+ doc? (
+ dev-python/sphinx-bootstrap-theme[${PYTHON_USEDEP}]
+ dev-python/numpydoc[${PYTHON_USEDEP}]
+ )
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/ipython[${PYTHON_USEDEP}]
+ )"
+
+python_prepare_all() {
+ # https://github.com/blink1073/oct2py/issues/77
+ sed \
+ -e 's:test_help:disabled:g' \
+ -i oct2py/tests/test_usage.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ if use doc; then
+ sphinx-build docs html || die
+ fi
+}
+
+python_test() {
+ unset DISPLAY
+ [[ ${EPYTHON} == python2.7 ]] && local OPTIONS="--with-doctest"
+ nosetests --exe -v oct2py ${OPTIONS} || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( html/. )
+ if use examples; then
+ docinto examples
+ dodoc -r example/.
+ fi
+
+ distutils-r1_python_install_all
+}