summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2017-08-19 22:38:22 +0000
committerSébastien Fabbro <bicatali@gentoo.org>2017-08-19 22:38:22 +0000
commit0231ca143f36c39090e5d64cc82f52cbc3dd1cc6 (patch)
treeba45de8b564796b9b71fafcd37221594deb799ce /dev-python/octave_kernel/octave_kernel-0.26.2.ebuild
parentdev-python/metakernel: initial import (diff)
downloadgentoo-0231ca143f36c39090e5d64cc82f52cbc3dd1cc6.tar.gz
gentoo-0231ca143f36c39090e5d64cc82f52cbc3dd1cc6.tar.bz2
gentoo-0231ca143f36c39090e5d64cc82f52cbc3dd1cc6.zip
dev-python/octave_kernel: initial import
Package-Manager: Portage-2.3.7, Repoman-2.3.3
Diffstat (limited to 'dev-python/octave_kernel/octave_kernel-0.26.2.ebuild')
-rw-r--r--dev-python/octave_kernel/octave_kernel-0.26.2.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/octave_kernel/octave_kernel-0.26.2.ebuild b/dev-python/octave_kernel/octave_kernel-0.26.2.ebuild
new file mode 100644
index 000000000000..f58a601bbbd2
--- /dev/null
+++ b/dev-python/octave_kernel/octave_kernel-0.26.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Jupyter kernel for octave"
+HOMEPAGE="https://github.com/Calysto/octave_kernel"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ dev-python/jupyter_client[${PYTHON_USEDEP}]
+ dev-python/metakernel[${PYTHON_USEDEP}]
+ sci-mathematics/octave
+"
+DEPEND="${RDEPEND}"