summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVirgil Dupras <vdupras@gentoo.org>2018-08-07 11:13:31 -0400
committerVirgil Dupras <vdupras@gentoo.org>2018-08-07 11:13:31 -0400
commit6e94fa9ed83e226d26a3ec95270cf3895f8f104a (patch)
tree85904093a69c1a344773c5d83e11f84b66a67d9c /dev-python/odfpy/odfpy-1.3.6.ebuild
parentnet-p2p/go-ipfs-bin: add services for openrc & systemd (diff)
downloadgentoo-6e94fa9ed83e226d26a3ec95270cf3895f8f104a.tar.gz
gentoo-6e94fa9ed83e226d26a3ec95270cf3895f8f104a.tar.bz2
gentoo-6e94fa9ed83e226d26a3ec95270cf3895f8f104a.zip
dev-python/odfpy: bump to 1.3.6
* Run tests properly (they pass now) * Use github release tarball to have complete content (for tests) * EAPI 7 * Python 3.7 Package-Manager: Portage-2.3.44, Repoman-2.3.10
Diffstat (limited to 'dev-python/odfpy/odfpy-1.3.6.ebuild')
-rw-r--r--dev-python/odfpy/odfpy-1.3.6.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/odfpy/odfpy-1.3.6.ebuild b/dev-python/odfpy/odfpy-1.3.6.ebuild
new file mode 100644
index 000000000000..61a31f54130d
--- /dev/null
+++ b/dev-python/odfpy/odfpy-1.3.6.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# Classifier: Programming Language :: Python :: 2 :: Only
+# py3 fails one test, pypy anpother.
+# Notes on page of home repo reports support of python3.
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6,3_7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python API and tools to manipulate OpenDocument files"
+HOMEPAGE="https://github.com/eea/odfpy https://pypi.org/project/odfpy/"
+SRC_URI="https://github.com/eea/${PN}/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0 GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_test() {
+ pytest -v || die "Tests failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}