summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2020-02-11 17:40:51 -0700
committerTim Harder <radhermit@gentoo.org>2020-02-11 17:50:06 -0700
commit633be6da7c023af9155f7dfda57c2ebe0de602ca (patch)
treed3bb1cc683481859acc2084d0178970e3dff21fd /dev-python/onkyo-eiscp/onkyo-eiscp-1.2.7.ebuild
parentdev-python/netifaces: add py38 compat (diff)
downloadgentoo-633be6da7c023af9155f7dfda57c2ebe0de602ca.tar.gz
gentoo-633be6da7c023af9155f7dfda57c2ebe0de602ca.tar.bz2
gentoo-633be6da7c023af9155f7dfda57c2ebe0de602ca.zip
dev-python/onkyo-eiscp: add py38 compat
Signed-off-by: Tim Harder <radhermit@gentoo.org>
Diffstat (limited to 'dev-python/onkyo-eiscp/onkyo-eiscp-1.2.7.ebuild')
-rw-r--r--dev-python/onkyo-eiscp/onkyo-eiscp-1.2.7.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/dev-python/onkyo-eiscp/onkyo-eiscp-1.2.7.ebuild b/dev-python/onkyo-eiscp/onkyo-eiscp-1.2.7.ebuild
index de7dad5a9036..629a015b6867 100644
--- a/dev-python/onkyo-eiscp/onkyo-eiscp-1.2.7.ebuild
+++ b/dev-python/onkyo-eiscp/onkyo-eiscp-1.2.7.ebuild
@@ -2,7 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{6,7} )
+PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
inherit distutils-r1
@@ -15,8 +16,7 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-RDEPEND="${DEPEND}
+RDEPEND="
>=dev-python/docopt-0.4.1[${PYTHON_USEDEP}]
dev-python/netifaces[${PYTHON_USEDEP}]
"