summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-06 18:05:34 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-06 18:05:34 +0100
commit1cc5345d5fa384584e675aa8ba118893499ee7a7 (patch)
tree9bfa9019abe8415b84012b7916cfd4a502722ebc /dev-python/openapi-spec-validator
parentdev-python/xmlschema: Bump to 2.2.0 (diff)
downloadgentoo-1cc5345d5fa384584e675aa8ba118893499ee7a7.tar.gz
gentoo-1cc5345d5fa384584e675aa8ba118893499ee7a7.tar.bz2
gentoo-1cc5345d5fa384584e675aa8ba118893499ee7a7.zip
dev-python/openapi-spec-validator: Bump to 0.5.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/openapi-spec-validator')
-rw-r--r--dev-python/openapi-spec-validator/Manifest1
-rw-r--r--dev-python/openapi-spec-validator/openapi-spec-validator-0.5.5.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/openapi-spec-validator/Manifest b/dev-python/openapi-spec-validator/Manifest
index 3ab4c384229a..79d28159ef28 100644
--- a/dev-python/openapi-spec-validator/Manifest
+++ b/dev-python/openapi-spec-validator/Manifest
@@ -3,3 +3,4 @@ DIST openapi-spec-validator-0.5.1.gh.tar.gz 39539 BLAKE2B 66adbed2c85527f89e510d
DIST openapi-spec-validator-0.5.2.gh.tar.gz 39743 BLAKE2B 92a4c4503add68c2683f4229f7b68b7cf98d38f36f3c03835b03be5e2a1092ebbb46a9f8d09bfb9e3cf7059a2a72ff01b81742986d479c2713dc6ef783718e00 SHA512 68f7d507a239c555575e2edb3bab576fd1fede9bcebde48c57361e3e764c9c19c4dc0d63e650851c2f6e7f2dd7f4efcdcd028842e259aa9e341823cd052a6e20
DIST openapi-spec-validator-0.5.3.gh.tar.gz 57006 BLAKE2B 0b92de74c3615789de5bb78340f75b5833172020aa8da987dd129ad24a339e93851d7830f9eb0be192af5cd35120bd5ec9601140e6edc964d5577950ac968bf5 SHA512 ef197f7bd05bcc7523a5b8992b602d5a7ea8c9cabe2166889d41ad764d2f96d7a90cbc11c247d7c33a33747cb2e6667bcbd279260d1bfc394769ef5fd1c19b25
DIST openapi-spec-validator-0.5.4.gh.tar.gz 57072 BLAKE2B d314fb62a106204fb706193c60b869a49d4e81a92d40ac73bd2f0b1cd01c7d6188f22e2299301974d1a90ec4d2a8e92f9895ab0643b6768f27230588fcac803d SHA512 234d5f284f71448f47cb82584ba8601c0bae13d85daad3452aae0c33d9e26d1e541bd96a17e9de33dbad1a7ebea0c362eced61497424c502a666075dd02bce33
+DIST openapi-spec-validator-0.5.5.gh.tar.gz 57200 BLAKE2B 037566130546d2cc894dd12e0fc0d80fe9631f94085ec286a61ea810c58b48cd7837cc044388773798a7684fa4d73bb89eed643a164280433c1cd8d6a9cd42cc SHA512 4b5415216e74937a0c6f527850921f362a3183119a641d4d369cbf3e6aa19209ec7d8ff05697eed7dcd1ee6d0e8fbcc9cb8aaa0e3eb46e4da34bc7a0a4b78c00
diff --git a/dev-python/openapi-spec-validator/openapi-spec-validator-0.5.5.ebuild b/dev-python/openapi-spec-validator/openapi-spec-validator-0.5.5.ebuild
new file mode 100644
index 000000000000..5951fb69acfe
--- /dev/null
+++ b/dev-python/openapi-spec-validator/openapi-spec-validator-0.5.5.ebuild
@@ -0,0 +1,56 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( pypy3 python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="OpenAPI 2.0 (aka Swagger) and OpenAPI 3.0 spec validator"
+HOMEPAGE="
+ https://github.com/p1c2u/openapi-spec-validator/
+ https://pypi.org/project/openapi-spec-validator/
+"
+SRC_URI="
+ https://github.com/p1c2u/openapi-spec-validator/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/jsonschema-4.0.0[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-spec-0.1.1[${PYTHON_USEDEP}]
+ >=dev-python/lazy-object-proxy-1.7.1[${PYTHON_USEDEP}]
+ <dev-python/openapi-schema-validator-0.5[${PYTHON_USEDEP}]
+ >=dev-python/openapi-schema-validator-0.3.2[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.1[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # Internet
+ tests/integration/test_shortcuts.py::TestPetstoreV2Example
+ tests/integration/test_shortcuts.py::TestApiV2WithExampe
+ tests/integration/test_shortcuts.py::TestPetstoreV2ExpandedExample
+ tests/integration/test_shortcuts.py::TestPetstoreExample
+ tests/integration/test_shortcuts.py::TestRemoteValidatev2SpecUrl
+ tests/integration/test_shortcuts.py::TestRemoteValidatev30SpecUrl
+ tests/integration/test_shortcuts.py::TestApiWithExample
+ tests/integration/test_shortcuts.py::TestPetstoreExpandedExample
+ tests/integration/test_validate.py::TestPetstoreExample
+ tests/integration/test_validate.py::TestApiWithExample
+ tests/integration/test_validate.py::TestPetstoreExpandedExample
+ tests/integration/validation/test_validators.py
+)
+
+src_prepare() {
+ sed -i -e '/--cov/d' pyproject.toml || die
+ distutils-r1_src_prepare
+}