summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-07-11 08:17:40 +0200
committerMichał Górny <mgorny@gentoo.org>2023-07-11 08:45:26 +0200
commit59c43a9f4bdcf849c5fbce1113de39b34278eb68 (patch)
treed73396eb7b26a1e84e13f8dab3bdd8fe21b11f07 /dev-python/openapi-spec-validator
parentsec-keys/openpgp-keys-apache-tomcat: dropped obsolete (diff)
downloadgentoo-59c43a9f4bdcf849c5fbce1113de39b34278eb68.tar.gz
gentoo-59c43a9f4bdcf849c5fbce1113de39b34278eb68.tar.bz2
gentoo-59c43a9f4bdcf849c5fbce1113de39b34278eb68.zip
dev-python/openapi-spec-validator: Bump to 0.6.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/openapi-spec-validator')
-rw-r--r--dev-python/openapi-spec-validator/Manifest1
-rw-r--r--dev-python/openapi-spec-validator/openapi-spec-validator-0.6.0.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/openapi-spec-validator/Manifest b/dev-python/openapi-spec-validator/Manifest
index ee8389786b3d..5e689e8ccfb9 100644
--- a/dev-python/openapi-spec-validator/Manifest
+++ b/dev-python/openapi-spec-validator/Manifest
@@ -1,2 +1,3 @@
DIST openapi_spec_validator-0.5.6.tar.gz 33031 BLAKE2B a884ceb915f232232406bd880a7eef9e588e1a42ac9a78c2e23f91cbd71e9af471c764550a9dd214ef68ec24ede7ab0ba4624429e4fd8133011489d0039aeae7 SHA512 ea1e810ecf49ff3d237e3368cd2cbcc6b733e9657f101759860ef16d3e2f14c97ccfe52fae2897d12a50c803d709d61d7ef8b40b288e5f73265da9ac5c88280b
DIST openapi_spec_validator-0.5.7.tar.gz 33722 BLAKE2B 71096a996d335b60d6646d96390e580952a1e27829aa807c4b333ee11a7925bc1bc10f4440c79fc6d4a8321dfd3bab9ec86bf79bef6c7139835b7f8035cbc061 SHA512 63dafc0bc459d8ad097d0a98a3d23e67ae37c0004ce6d53ad999b037f2a6743c95e13ae22920403368c37f8877665c104ac20e1f58532cffd8df54c800a6cf7d
+DIST openapi_spec_validator-0.6.0.tar.gz 33646 BLAKE2B cf8d397602b147872e86c0f236731ec477e20775aa63a61162e66deb7d4b81ef91bd86b67d2dfddf5d6b160c37b7eab4ddb1d10975ada8dc13aebdc088e4483a SHA512 71434f131f34902210237940d75f07f250b296c3e1814e03f0eaae436321ca11ac63d0014c85ad571852e66b2e11545c9d0cf21d771c0c67210a60c1f9094cc2
diff --git a/dev-python/openapi-spec-validator/openapi-spec-validator-0.6.0.ebuild b/dev-python/openapi-spec-validator/openapi-spec-validator-0.6.0.ebuild
new file mode 100644
index 000000000000..3bcaf2ceef03
--- /dev/null
+++ b/dev-python/openapi-spec-validator/openapi-spec-validator-0.6.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( pypy3 python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="OpenAPI 2.0 (aka Swagger) and OpenAPI 3.0 spec validator"
+HOMEPAGE="
+ https://github.com/python-openapi/openapi-spec-validator/
+ https://pypi.org/project/openapi-spec-validator/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+
+RDEPEND="
+ >=dev-python/jsonschema-4.18.0[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-spec-0.2.3[${PYTHON_USEDEP}]
+ >=dev-python/lazy-object-proxy-1.7.1[${PYTHON_USEDEP}]
+ >=dev-python/openapi-schema-validator-0.6.0[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.1[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # Internet
+ tests/integration/test_shortcuts.py::TestPetstoreV2Example
+ tests/integration/test_shortcuts.py::TestApiV2WithExampe
+ tests/integration/test_shortcuts.py::TestPetstoreV2ExpandedExample
+ tests/integration/test_shortcuts.py::TestPetstoreExample
+ tests/integration/test_shortcuts.py::TestRemoteValidatev2SpecUrl
+ tests/integration/test_shortcuts.py::TestRemoteValidatev30SpecUrl
+ tests/integration/test_shortcuts.py::TestApiWithExample
+ tests/integration/test_shortcuts.py::TestPetstoreExpandedExample
+ tests/integration/test_validate.py::TestPetstoreExample
+ tests/integration/test_validate.py::TestApiWithExample
+ tests/integration/test_validate.py::TestPetstoreExpandedExample
+ tests/integration/validation/test_validators.py
+)
+
+src_prepare() {
+ sed -i -e '/--cov/d' pyproject.toml || die
+ distutils-r1_src_prepare
+}