summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2020-10-04 14:11:43 +0200
committerLouis Sautier <sbraz@gentoo.org>2020-10-04 14:17:19 +0200
commit500a2e9d56bce0f407d4274b97c337571b2d7cfb (patch)
tree8495c5bc8efc509a94627b7b18a821982ab3cae8 /dev-python/openstackdocstheme/openstackdocstheme-2.2.5.ebuild
parentapp-misc/lfm: set DISTUTILS_USE_SETUPTOOLS=no (diff)
downloadgentoo-500a2e9d56bce0f407d4274b97c337571b2d7cfb.tar.gz
gentoo-500a2e9d56bce0f407d4274b97c337571b2d7cfb.tar.bz2
gentoo-500a2e9d56bce0f407d4274b97c337571b2d7cfb.zip
dev-python/openstackdocstheme: bump to 2.2.5, support Python 3.{8,9}
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Louis Sautier <sbraz@gentoo.org>
Diffstat (limited to 'dev-python/openstackdocstheme/openstackdocstheme-2.2.5.ebuild')
-rw-r--r--dev-python/openstackdocstheme/openstackdocstheme-2.2.5.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/openstackdocstheme/openstackdocstheme-2.2.5.ebuild b/dev-python/openstackdocstheme/openstackdocstheme-2.2.5.ebuild
new file mode 100644
index 000000000000..2d4348b40bbf
--- /dev/null
+++ b/dev-python/openstackdocstheme/openstackdocstheme-2.2.5.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Theme and extension support for Sphinx documentation"
+HOMEPAGE="https://docs.openstack.org/openstackdocstheme/latest/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc64 ~x86"
+
+DEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}
+ >=dev-python/dulwich-0.15.0[${PYTHON_USEDEP}]"